Upstream information

CVE-2009-3230 at MITRE


The core server component in PostgreSQL 8.4 before 8.4.1, 8.3 before 8.3.8, 8.2 before 8.2.14, 8.1 before 8.1.18, 8.0 before 8.0.22, and 7.4 before 7.4.26 does not use the appropriate privileges for the (1) RESET ROLE and (2) RESET SESSION AUTHORIZATION operations, which allows remote authenticated users to gain privileges. NOTE: this is due to an incomplete fix for CVE-2007-6600.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 537706 [RESOLVED / FIXED], 603970 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • postgresql >= 8.3.8-0.1.1
  • postgresql-contrib >= 8.3.8-0.1.1
  • postgresql-docs >= 8.3.8-0.1.1
  • postgresql-libs >= 8.3.8-0.1.1
  • postgresql-libs-32bit >= 8.3.8-0.1.1
  • postgresql-libs-x86 >= 8.3.8-0.1.1
  • postgresql-server >= 8.3.8-0.1.1

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 postgresql Released
SLES-10-SP3 postgresql Released
SUSE Linux Enterprise Desktop 11 postgresql Released