Upstream information

CVE-2009-2905 at MITRE

Description

Heap-based buffer overflow in textbox.c in newt 0.51.5, 0.51.6, and 0.52.2 allows local users to cause a denial of service (application crash) or possibly execute arbitrary code via a request to display a crafted text dialog box.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 540930 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libnewt0_52 >= 0.52.16-1.83
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libnewt0_52 >= 0.52.20-5.35
  • newt >= 0.52.20-5.35
  • python3-newt >= 0.52.20-5.35
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • newt-devel >= 0.52.20-5.35
SUSE Linux Enterprise Server 11 SP2
  • libnewt0_52 >= 0.52.10-1.35.7
  • newt >= 0.52.10-1.35.7
  • python-newt >= 0.52.10-1.35.7
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • libnewt0_52 >= 0.52.10-1.35.113
  • newt >= 0.52.10-1.35.113
  • python-newt >= 0.52.10-1.35.113
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libnewt0_52 >= 0.52.10-1.35.113
  • newt >= 0.52.10-1.35.113
  • newt-devel >= 0.52.10-1.35.7
  • newt-static >= 0.52.10-1.35.7
  • python-newt >= 0.52.10-1.35.113
SUSE Linux Enterprise Software Development Kit 12
  • newt-devel >= 0.52.16-1.83
  • newt-static >= 0.52.16-1.83
openSUSE Leap 15.0
  • libnewt0_52 >= 0.52.20-lp150.5.5
Patchnames:
openSUSE Leap 15.0 GA libnewt0_52-0.52.20-lp150.5.5
openSUSE Tumbleweed
  • libnewt0_52 >= 0.52.18-1.9
  • libnewt0_52-32bit >= 0.52.18-1.9
  • newt >= 0.52.18-1.9
  • newt-devel >= 0.52.18-1.9
  • newt-doc >= 0.52.18-1.9
  • newt-static >= 0.52.18-1.9
  • python-newt >= 0.52.18-1.9
Patchnames:
openSUSE Tumbleweed GA libnewt0_52-0.52.18-1.9


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 newt Released
SUSE Linux Enterprise Server 11 newt Released
SUSE Linux Enterprise Software Development Kit 11 newt Released