Upstream information

CVE-2009-2730 at MITRE

Description

libgnutls in GnuTLS before 2.8.2 does not properly handle a '\0' character in a domain name in the subject's (1) Common Name (CN) or (2) Subject Alternative Name (SAN) field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 392947 [RESOLVED / FIXED], 528372 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • gnutls >= 2.4.1-24.19.1
  • libgnutls26 >= 2.4.1-24.19.1
  • libgnutls26-32bit >= 2.4.1-24.19.1
  • libgnutls26-x86 >= 2.4.1-24.19.1
SUSE Linux Enterprise Server 11 SP2
  • gnutls >= 2.4.1-24.39.33.1
  • libgnutls26 >= 2.4.1-24.39.33.1
  • libgnutls26-32bit >= 2.4.1-24.39.33.1
  • libgnutls26-x86 >= 2.4.1-24.39.33.1
SUSE Linux Enterprise Server 11 SP3
  • gnutls >= 2.4.1-24.39.45.1
  • libgnutls-extra26 >= 2.4.1-24.39.45.1
  • libgnutls26 >= 2.4.1-24.39.45.1
  • libgnutls26-32bit >= 2.4.1-24.39.45.1
  • libgnutls26-x86 >= 2.4.1-24.39.45.1
SUSE Linux Enterprise Server 11 SP4
  • gnutls >= 2.4.1-24.39.55.1
  • libgnutls-extra26 >= 2.4.1-24.39.55.1
  • libgnutls26 >= 2.4.1-24.39.55.1
  • libgnutls26-32bit >= 2.4.1-24.39.55.1
  • libgnutls26-x86 >= 2.4.1-24.39.55.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • gnutls >= 2.4.1-24.19.1
  • libgnutls26 >= 2.4.1-24.19.1
  • libgnutls26-32bit >= 2.4.1-24.19.1
  • libgnutls26-x86 >= 2.4.1-24.19.1
Patchnames:
slessp0-gnutls
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgnutls-devel >= 2.4.1-24.39.55.1
  • libgnutls-extra-devel >= 2.4.1-24.39.55.1
  • libgnutls-extra26 >= 2.4.1-24.39.55.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
gnutls Released
SLED-10-SP3 gnutls Unsupported
SLED-10-SP4 gnutls Affected
SLES for SAP Applications gnutls Affected
SLES-10-SP3 gnutls Unsupported
SLES-10-SP4 gnutls Affected
SLES_LTSS-10-SP4 gnutls Affected
SUSE Linux Enterprise Desktop 11 gnutls Affected
SUSE Linux Enterprise Desktop 11 SP1 gnutls Affected
SUSE Linux Enterprise Desktop 11 SP2 gnutls Affected
SUSE Linux Enterprise Desktop 11 SP3 gnutls Affected
SUSE Linux Enterprise Desktop 11 SP4 gnutls Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search gnutls Affected
SUSE Linux Enterprise High Availability Extension 11 gnutls Affected
SUSE Linux Enterprise High Availability Extension 11 SP1 gnutls Affected
SUSE Linux Enterprise High Availability Extension 11 SP3 gnutls Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Affected
SUSE Linux Enterprise Server 11 SP1 gnutls Affected
SUSE Linux Enterprise Server 11 SP1 LTSS gnutls Affected
SUSE Linux Enterprise Server 11 SP2 gnutls Affected
SUSE Linux Enterprise Server 11 SP2 LTSS gnutls Affected
SUSE Linux Enterprise Server 11 SP2 for VMware gnutls Affected
SUSE Linux Enterprise Server 11 SP3 gnutls Affected
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Affected
SUSE Linux Enterprise Server 11 SP3 for VMware gnutls Affected
SUSE Linux Enterprise Server 11 SP4 gnutls Affected
SUSE Linux Enterprise Server 11 SP4 LTSS gnutls Affected
SUSE Linux Enterprise Server for SAP Business All-in-One gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 gnutls Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 gnutls Affected