Upstream information

CVE-2009-1570 at MITRE

Description

Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 555144 [RESOLVED / FIXED], 555166 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gimp >= 2.6.2-3.34.45.1
  • gimp-devel >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 gimp Released
SUSE Linux Enterprise Desktop 11 gimp Released
SUSE Linux Enterprise Desktop 11 SP1 gimp Released
SUSE Linux Enterprise Desktop 11 SP2 gimp Released
SUSE Linux Enterprise Desktop 11 SP3 gimp Released
SUSE Linux Enterprise Desktop 11 SP4 gimp Released
SUSE Linux Enterprise Software Development Kit 11 gimp Released
SUSE Linux Enterprise Software Development Kit 11 SP1 gimp Released
SUSE Linux Enterprise Software Development Kit 11 SP2 gimp Released
SUSE Linux Enterprise Software Development Kit 11 SP3 gimp Released
SUSE Linux Enterprise Software Development Kit 11 SP4 gimp Released