Upstream information

CVE-2009-0791 at MITRE

Description

Multiple integer overflows in Xpdf 2.x and 3.x and Poppler 0.x, as used in the pdftops filter in CUPS 1.1.17, 1.1.22, and 1.3.7, GPdf, and kdegraphics KPDF, allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PDF file that triggers a heap-based buffer overflow, possibly related to (1) Decrypt.cxx, (2) FoFiTrueType.cxx, (3) gmem.c, (4) JBIG2Stream.cxx, and (5) PSOutputDev.cxx in pdftops/. NOTE: the JBIG2Stream.cxx vector may overlap CVE-2009-1179.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 502061 [RESOLVED / FIXED], 502974 [RESOLVED / FIXED], 507102 [RESOLVED / FIXED], 539875 [RESOLVED / FIXED], 556049 [RESOLVED / FIXED], 566697 [RESOLVED / FIXED], 570183 [CLOSED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libpoppler-glib4 >= 0.12.3-1.2.44
  • libpoppler-qt4-3 >= 0.12.3-1.2.44
  • libpoppler5 >= 0.12.3-1.2.44
  • poppler-tools >= 0.12.3-1.2.44
  • xpdf-tools >= 3.02-138.26.1
SUSE Linux Enterprise Server 11 SP2
  • libpoppler-glib4 >= 0.12.3-1.3.1
  • libpoppler-qt4-3 >= 0.12.3-1.3.1
  • libpoppler5 >= 0.12.3-1.3.1
  • poppler-tools >= 0.12.3-1.3.1
SUSE Linux Enterprise Server 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
SUSE Linux Enterprise Server 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • libpoppler-glib4 >= 0.10.1-1.31.1
  • libpoppler-qt4-3 >= 0.10.1-1.31.1
  • libpoppler4 >= 0.10.1-1.31.1
  • poppler-tools >= 0.10.1-1.31.1
  • xpdf-tools >= 3.02-138.26.1
Patchnames:
slessp0-libpoppler-devel
slessp0-xpdf
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 poppler Released
SLED-10-SP4 poppler Released
SLES for SAP Applications xpdf Released
SLES-10-SP3 poppler Released
SLES-10-SP4 poppler Released
SLES_LTSS-10-SP4 poppler Released
SUSE Linux Enterprise Desktop 11 cups Affected
SUSE Linux Enterprise Desktop 11 poppler Released
SUSE Linux Enterprise Desktop 11 xpdf Released
SUSE Linux Enterprise Desktop 11 SP1 xpdf Released
SUSE Linux Enterprise Desktop 11 SP2 xpdf Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search xpdf Released
SUSE Linux Enterprise Server 11 poppler Released
SUSE Linux Enterprise Server 11 SP1 xpdf Released
SUSE Linux Enterprise Server 11 SP1 LTSS xpdf Released
SUSE Linux Enterprise Server 11 SP2 xpdf Released
SUSE Linux Enterprise Server 11 SP2 LTSS xpdf Released
SUSE Linux Enterprise Server 11 SP2 for VMware xpdf Released
SUSE Linux Enterprise Server for SAP Business All-in-One xpdf Released
SUSE Linux Enterprise Software Development Kit 11 cups Affected
SUSE Linux Enterprise Software Development Kit 11 poppler Released