Upstream information

CVE-2009-0723 at MITRE

Description

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 479606 [RESOLVED / FIXED], 490610 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
  • liblcms1-32bit >= 1.17-77.12.1
  • liblcms1-x86 >= 1.17-77.12.1
Patchnames:
slessp0-lcms
SUSE Linux Enterprise Server 11 SP1
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA lcms
SUSE Linux Enterprise Server 11 SP2
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA lcms
SUSE Linux Enterprise Server 11 SP3
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA lcms
SUSE Linux Enterprise Server 11 SP4
  • lcms >= 1.17-77.16.1
  • liblcms1 >= 1.17-77.16.1
  • liblcms1-32bit >= 1.17-77.16.1
  • liblcms1-x86 >= 1.17-77.16.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA lcms
SUSE Linux Enterprise Server for SAP Applications 11
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
  • liblcms1-32bit >= 1.17-77.12.1
  • liblcms1-x86 >= 1.17-77.12.1
Patchnames:
slessp0-lcms
SUSE Linux Enterprise Software Development Kit 11 SP4
  • liblcms-devel >= 1.17-77.16.1
  • liblcms-devel-32bit >= 1.17-77.16.1
  • python-lcms >= 1.17-77.16.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA liblcms-devel
openSUSE 11.0
  • lcms-debuginfo >= 1.17-40.2
  • lcms-debugsource >= 1.17-40.2
openSUSE 11.0
  • lcms >= 1.17-40.2
  • liblcms-devel >= 1.17-40.2
  • liblcms-devel-32bit >= 1.17-40.2
  • liblcms-devel-64bit >= 1.17-40.2
  • liblcms1 >= 1.17-40.2
  • liblcms1-32bit >= 1.17-40.2
  • liblcms1-64bit >= 1.17-40.2
openSUSE 11.1
  • lcms-debuginfo >= 1.17-44.59.1
  • lcms-debugsource >= 1.17-44.59.1
openSUSE 11.1
  • lcms >= 1.17-44.59.1
  • liblcms-devel >= 1.17-44.59.1
  • liblcms-devel-32bit >= 1.17-44.59.1
  • liblcms-devel-64bit >= 1.17-44.59.2
  • liblcms1 >= 1.17-44.59.1
  • liblcms1-32bit >= 1.17-44.59.1
  • liblcms1-64bit >= 1.17-44.59.2
  • python-lcms >= 1.17-44.59.1
openSUSE 11.0
  • java-1_6_0-openjdk-debuginfo >= 1.4_b14-24.3
  • java-1_6_0-openjdk-debugsource >= 1.4_b14-24.3
openSUSE 11.0
  • java-1_6_0-openjdk >= 1.4_b14-24.3
  • java-1_6_0-openjdk-demo >= 1.4_b14-24.3
  • java-1_6_0-openjdk-devel >= 1.4_b14-24.3
  • java-1_6_0-openjdk-javadoc >= 1.4_b14-24.3
  • java-1_6_0-openjdk-plugin >= 1.4_b14-24.3
  • java-1_6_0-openjdk-src >= 1.4_b14-24.3
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • liblcms >= 1.12-55.7
  • liblcms-devel >= 1.12-55.7
core9.ppc
core9.s390
core9.x86
core9.x86-64
sles9-nld.x86
sles9-nlpos.x86
core9.s390x
sles9-nld.x86-64
sles9-oes.x86
core9.ia64
YOU Patch Nr: 12361
Novell Linux Desktop 9 for x86_64
  • liblcms >= 1.12-55.7
  • liblcms-32bit >= 9-200903091206
  • liblcms-devel >= 1.12-55.7
core9.ppc
core9.s390
core9.x86
core9.x86-64
sles9-nld.x86
sles9-nlpos.x86
core9.s390x
sles9-nld.x86-64
sles9-oes.x86
core9.ia64
YOU Patch Nr: 12361
openSUSE 11.1
  • java-1_6_0-openjdk-debuginfo >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-debuginfo >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-debugsource >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-debugsource >= 1.4_b14-24.3.3
openSUSE 11.1
  • java-1_6_0-openjdk >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-demo >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-demo >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-devel >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-devel >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-javadoc >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-javadoc >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-plugin >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-plugin >= 1.4_b14-24.3.3
  • java-1_6_0-openjdk-src >= 1.4_b14-24.3.1
  • java-1_6_0-openjdk-src >= 1.4_b14-24.3.3
SUSE Linux Enterprise SDK 11 GA
  • liblcms-devel >= 1.17-77.12.1
  • python-lcms >= 1.17-77.12.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sles11.s390x
sle11-sdk.ia64
sle11-sdk.x86-64
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sles11.ia64
sle11-debuginfo.x86
sles11.ppc
sles11.x86
sle11-sdk.s390x
sle11-sdk.ppc
sle11-debuginfo.ppc
sles11.x86-64
SAT Patch Nr: 635
SUSE Linux Enterprise SDK 11 GA
  • liblcms-devel >= 1.17-77.12.1
  • liblcms-devel-32bit >= 1.17-77.12.1
  • python-lcms >= 1.17-77.12.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sles11.s390x
sle11-sdk.ia64
sle11-sdk.x86-64
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sles11.ia64
sle11-debuginfo.x86
sles11.ppc
sles11.x86
sle11-sdk.s390x
sle11-sdk.ppc
sle11-debuginfo.ppc
sles11.x86-64
SAT Patch Nr: 635
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sles11.s390x
sle11-sdk.ia64
sle11-sdk.x86-64
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sles11.ia64
sle11-debuginfo.x86
sles11.ppc
sles11.x86
sle11-sdk.s390x
sle11-sdk.ppc
sle11-debuginfo.ppc
sles11.x86-64
SAT Patch Nr: 635
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
  • liblcms1-32bit >= 1.17-77.12.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sles11.s390x
sle11-sdk.ia64
sle11-sdk.x86-64
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sles11.ia64
sle11-debuginfo.x86
sles11.ppc
sles11.x86
sle11-sdk.s390x
sle11-sdk.ppc
sle11-debuginfo.ppc
sles11.x86-64
SAT Patch Nr: 635
SUSE Linux Enterprise Server 11 GA
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
  • liblcms1-x86 >= 1.17-77.12.1
sled11.x86-64
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sles11.s390x
sle11-sdk.ia64
sle11-sdk.x86-64
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sles11.ia64
sle11-debuginfo.x86
sles11.ppc
sles11.x86
sle11-sdk.s390x
sle11-sdk.ppc
sle11-debuginfo.ppc
sles11.x86-64
SAT Patch Nr: 635


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA lcms Released
SUSE Linux Enterprise SDK 11 GA lcms Released
SUSE Linux Enterprise Server 11 GA lcms Released