Upstream information

CVE-2009-0723 at MITRE

Description

Multiple integer overflows in LittleCMS (aka lcms or liblcms) before 1.18beta2, as used in Firefox 3.1beta, OpenJDK, and GIMP, allow context-dependent attackers to execute arbitrary code via a crafted image file that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 479606 [RESOLVED / FIXED], 490610 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • liblcms-devel >= 1.17-77.16.1
  • liblcms-devel-32bit >= 1.17-77.16.1
  • python-lcms >= 1.17-77.16.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA liblcms-devel-1.17-77.16.1
SUSE Linux Enterprise Server 11 SP1
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA lcms-1.17-77.14.19
SUSE Linux Enterprise Server 11 SP2
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA lcms-1.17-77.14.19
SUSE Linux Enterprise Server 11 SP3
  • lcms >= 1.17-77.14.19
  • liblcms1 >= 1.17-77.14.19
  • liblcms1-32bit >= 1.17-77.14.19
  • liblcms1-x86 >= 1.17-77.14.19
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA lcms-1.17-77.14.19
SUSE Linux Enterprise Server 11 SP4
  • lcms >= 1.17-77.16.1
  • liblcms-devel >= 1.17-77.16.1
  • liblcms-devel-32bit >= 1.17-77.16.1
  • liblcms1 >= 1.17-77.16.1
  • liblcms1-32bit >= 1.17-77.16.1
  • liblcms1-x86 >= 1.17-77.16.1
  • python-lcms >= 1.17-77.16.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA lcms-1.17-77.16.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA liblcms-devel-1.17-77.16.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • lcms >= 1.17-77.12.1
  • liblcms1 >= 1.17-77.12.1
  • liblcms1-32bit >= 1.17-77.12.1
  • liblcms1-x86 >= 1.17-77.12.1
Patchnames:
slessp0-lcms


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 lcms Released
SUSE Linux Enterprise Server 11 lcms Released
SUSE Linux Enterprise Server for SAP Applications 11 lcms Released
SUSE Linux Enterprise Software Development Kit 11 lcms Released