Upstream information

CVE-2009-0689 at MITRE

Description

Array index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conversion to a floating-point number.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.4
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entries: 522109 [RESOLVED / FIXED], 545277 [RESOLVED / FIXED], 546371 [RESOLVED / FIXED], 557126 [RESOLVED / FIXED], 557127 [RESOLVED / FIXED], 557128 [RESOLVED / FIXED], 557671 [RESOLVED / FIXED], 590499 [RESOLVED / FIXED], 607935 [RESOLVED / FIXED], 851803 [RESOLVED / FIXED], 958097 [RESOLVED / FIXED], 963818 [RESOLVED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • kdelibs3-32bit >= 3.5.10-23.27.1
  • kdelibs3-arts >= 3.5.10-23.27.1
  • kdelibs3-arts-32bit >= 3.5.10-23.27.1
  • kdelibs3-arts-x86 >= 3.5.10-23.27.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.27.1
  • kdelibs3-devel >= 3.5.10-23.27.1
  • kdelibs3-doc >= 3.5.10-23.27.1
  • kdelibs4-doc >= 4.3.5-0.14.1
  • libkde4-32bit >= 4.3.5-0.14.1
  • libkde4-devel >= 4.3.5-0.14.1
  • libkdecore4-32bit >= 4.3.5-0.14.1
  • libkdecore4-devel >= 4.3.5-0.14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA kdelibs3-32bit-3.5.10-23.27.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA kdelibs4-doc-4.3.5-0.14.1
SUSE Linux Enterprise Server 11 SP1
  • kdelibs3 >= 3.5.10-23.27.1
  • kdelibs3-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style >= 3.5.10-23.27.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.27.1
  • kdelibs3-x86 >= 3.5.10-23.27.1
  • kdelibs4 >= 4.3.5-0.2.46
  • kdelibs4-core >= 4.3.5-0.2.46
  • kdelibs4-doc >= 4.3.5-0.2.46
  • libkde4 >= 4.3.5-0.2.46
  • libkde4-32bit >= 4.3.5-0.2.46
  • libkde4-x86 >= 4.3.5-0.2.46
  • libkdecore4 >= 4.3.5-0.2.46
  • libkdecore4-32bit >= 4.3.5-0.2.46
  • libkdecore4-x86 >= 4.3.5-0.2.46
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA kdelibs3-3.5.10-23.27.1
SUSE Linux Enterprise Server 11 SP1 GA kdelibs4-4.3.5-0.2.46
SUSE Linux Enterprise Server 11 SP2
  • kdelibs3 >= 3.5.10-23.27.1
  • kdelibs3-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style >= 3.5.10-23.27.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.27.1
  • kdelibs3-x86 >= 3.5.10-23.27.1
  • kdelibs4 >= 4.3.5-0.6.1
  • kdelibs4-core >= 4.3.5-0.6.1
  • kdelibs4-doc >= 4.3.5-0.6.1
  • libkde4 >= 4.3.5-0.6.1
  • libkde4-32bit >= 4.3.5-0.6.1
  • libkde4-x86 >= 4.3.5-0.6.1
  • libkdecore4 >= 4.3.5-0.6.1
  • libkdecore4-32bit >= 4.3.5-0.6.1
  • libkdecore4-x86 >= 4.3.5-0.6.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA kdelibs3-3.5.10-23.27.1
SUSE Linux Enterprise Server 11 SP2 GA kdelibs4-4.3.5-0.6.1
SUSE Linux Enterprise Server 11 SP3
  • kdelibs3 >= 3.5.10-23.27.1
  • kdelibs3-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style >= 3.5.10-23.27.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.27.1
  • kdelibs3-x86 >= 3.5.10-23.27.1
  • kdelibs4 >= 4.3.5-0.10.1
  • kdelibs4-core >= 4.3.5-0.10.1
  • kdelibs4-doc >= 4.3.5-0.10.1
  • libkde4 >= 4.3.5-0.10.1
  • libkde4-32bit >= 4.3.5-0.10.1
  • libkde4-x86 >= 4.3.5-0.10.1
  • libkdecore4 >= 4.3.5-0.10.1
  • libkdecore4-32bit >= 4.3.5-0.10.1
  • libkdecore4-x86 >= 4.3.5-0.10.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA kdelibs3-3.5.10-23.27.1
SUSE Linux Enterprise Server 11 SP3 GA kdelibs4-4.3.5-0.10.1
SUSE Linux Enterprise Server 11 SP4
  • kdelibs3 >= 3.5.10-23.27.1
  • kdelibs3-32bit >= 3.5.10-23.27.1
  • kdelibs3-arts >= 3.5.10-23.27.1
  • kdelibs3-arts-32bit >= 3.5.10-23.27.1
  • kdelibs3-arts-x86 >= 3.5.10-23.27.1
  • kdelibs3-default-style >= 3.5.10-23.27.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.27.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.27.1
  • kdelibs3-devel >= 3.5.10-23.27.1
  • kdelibs3-doc >= 3.5.10-23.27.1
  • kdelibs3-x86 >= 3.5.10-23.27.1
  • kdelibs4 >= 4.3.5-0.14.1
  • kdelibs4-core >= 4.3.5-0.14.1
  • kdelibs4-doc >= 4.3.5-0.14.1
  • libkde4 >= 4.3.5-0.14.1
  • libkde4-32bit >= 4.3.5-0.14.1
  • libkde4-devel >= 4.3.5-0.14.1
  • libkde4-x86 >= 4.3.5-0.14.1
  • libkdecore4 >= 4.3.5-0.14.1
  • libkdecore4-32bit >= 4.3.5-0.14.1
  • libkdecore4-devel >= 4.3.5-0.14.1
  • libkdecore4-x86 >= 4.3.5-0.14.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA kdelibs3-3.5.10-23.27.1
SUSE Linux Enterprise Server 11 SP4 GA kdelibs4-4.3.5-0.14.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA kdelibs3-32bit-3.5.10-23.27.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA kdelibs4-doc-4.3.5-0.14.1
openSUSE Tumbleweed
  • kdelibs3 >= 3.5.10-89.3
  • kdelibs3-32bit >= 3.5.10-89.3
  • kdelibs3-arts >= 3.5.10-89.3
  • kdelibs3-arts-32bit >= 3.5.10-89.3
  • kdelibs3-default-style >= 3.5.10-89.3
  • kdelibs3-default-style-32bit >= 3.5.10-89.3
  • kdelibs3-devel >= 3.5.10-89.3
  • kdelibs3-doc >= 3.5.10-89.3
Patchnames:
openSUSE Tumbleweed GA kdelibs3-3.5.10-89.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 MozillaFirefox Already fixed
SUSE Enterprise Storage 6 MozillaFirefox Already fixed
SUSE Linux Enterprise Desktop 11 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 mozilla-nspr Released
SUSE Linux Enterprise Desktop 11 SP1 mozilla-nspr Released
SUSE Linux Enterprise Desktop 15 SP4 mozilla-nspr Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS MozillaFirefox Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 mozilla-nspr Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS MozillaFirefox Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 mozilla-nspr Not affected
SUSE Linux Enterprise Point of Service 11 SP3 mono-core In progress
SUSE Linux Enterprise Server 11 MozillaFirefox Released
SUSE Linux Enterprise Server 11 mozilla-nspr Released
SUSE Linux Enterprise Server 11 SP1 mozilla-nspr Released
SUSE Linux Enterprise Server 11 SP4 LTSS mono-core In progress
SUSE Linux Enterprise Server 15 SP1-LTSS MozillaFirefox Already fixed
SUSE Linux Enterprise Server 15 SP4 mozilla-nspr Not affected
SUSE Linux Enterprise Server 15-ESPOS MozillaFirefox Already fixed
SUSE Linux Enterprise Server 15-LTSS MozillaFirefox Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 MozillaFirefox Already fixed
SUSE Linux Enterprise Server for SAP Applications 11 mozilla-nspr Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 mozilla-nspr Released
SUSE Linux Enterprise Server for SAP Applications 15 MozillaFirefox Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 MozillaFirefox Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 mozilla-nspr Not affected
SUSE Linux Enterprise Software Development Kit 11 mozilla-nspr Released
SUSE Linux Enterprise Software Development Kit 11 SP1 mozilla-nspr Released
SUSE Manager Proxy 4.0 MozillaFirefox In progress
SUSE Manager Proxy 4.3 mozilla-nspr Not affected
SUSE Manager Retail Branch Server 4.0 MozillaFirefox In progress
SUSE Manager Retail Branch Server 4.3 mozilla-nspr Not affected
SUSE Manager Server 4.0 MozillaFirefox In progress
SUSE Manager Server 4.3 mozilla-nspr Not affected
bci/openjdk
bci/openjdk-devel
bci/openjdk-devel:11
bci/openjdk:17
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
suse/389-ds
suse/pcp
suse/sle-micro-rancher/5.3
mozilla-nsprNot affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 03:37:27 2013
CVE page last modified: Tue Nov 29 00:35:24 2022