Upstream information

CVE-2009-0583 at MITRE

Description

Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 483303 [RESOLVED / FIXED], 491897 [RESOLVED / FIXED], 492765 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • ghostscript-fonts-other >= 8.62-32.22.2
  • ghostscript-fonts-rus >= 8.62-32.22.2
  • ghostscript-fonts-std >= 8.62-32.22.2
  • ghostscript-library >= 8.62-32.22.2
  • ghostscript-omni >= 8.62-32.22.2
  • ghostscript-x11 >= 8.62-32.22.2
  • libgimpprint >= 4.2.7-32.22.2
Patchnames:
slessp0-ghostscript-devel
SUSE Linux Enterprise Server 11 SP1
  • ghostscript-fonts-other >= 8.62-32.27.31
  • ghostscript-fonts-rus >= 8.62-32.27.31
  • ghostscript-fonts-std >= 8.62-32.27.31
  • ghostscript-library >= 8.62-32.27.31
  • ghostscript-omni >= 8.62-32.27.31
  • ghostscript-x11 >= 8.62-32.27.31
  • libgimpprint >= 4.2.7-32.27.31
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ghostscript-fonts-other
SUSE Linux Enterprise Server 11 SP2
  • ghostscript-fonts-other >= 8.62-32.28.1
  • ghostscript-fonts-rus >= 8.62-32.28.1
  • ghostscript-fonts-std >= 8.62-32.28.1
  • ghostscript-library >= 8.62-32.28.1
  • ghostscript-omni >= 8.62-32.28.1
  • ghostscript-x11 >= 8.62-32.28.1
  • libgimpprint >= 4.2.7-32.28.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ghostscript-fonts-other
SUSE Linux Enterprise Server 11 SP3
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ghostscript-fonts-other
SUSE Linux Enterprise Server 11 SP4
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ghostscript-fonts-other
SUSE Linux Enterprise Server for SAP Applications 11
  • ghostscript-fonts-other >= 8.62-32.22.2
  • ghostscript-fonts-rus >= 8.62-32.22.2
  • ghostscript-fonts-std >= 8.62-32.22.2
  • ghostscript-library >= 8.62-32.22.2
  • ghostscript-omni >= 8.62-32.22.2
  • ghostscript-x11 >= 8.62-32.22.2
  • libgimpprint >= 4.2.7-32.22.2
Patchnames:
slessp0-ghostscript-devel
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ghostscript-devel
openSUSE 11.0
  • ghostscript-library-debuginfo >= 8.62-17.2
  • ghostscript-library-debugsource >= 8.62-17.2
openSUSE 11.0
  • ghostscript-devel >= 8.62-17.2
  • ghostscript-fonts-other >= 8.62-17.2
  • ghostscript-fonts-rus >= 8.62-17.2
  • ghostscript-fonts-std >= 8.62-17.2
  • ghostscript-ijs-devel >= 8.62-17.2
  • ghostscript-library >= 8.62-17.2
  • ghostscript-omni >= 8.62-17.2
  • ghostscript-x11 >= 8.62-17.2
  • libgimpprint >= 4.2.7-258.2
  • libgimpprint-devel >= 4.2.7-258.2
openSUSE 11.1
  • ghostscript-library-debuginfo >= 8.62-31.40.1
  • ghostscript-library-debugsource >= 8.62-31.40.1
openSUSE 11.1
  • ghostscript-devel >= 8.62-31.40.1
  • ghostscript-fonts-other >= 8.62-31.40.1
  • ghostscript-fonts-rus >= 8.62-31.40.1
  • ghostscript-fonts-std >= 8.62-31.40.1
  • ghostscript-ijs-devel >= 8.62-31.40.1
  • ghostscript-library >= 8.62-31.40.1
  • ghostscript-omni >= 8.62-31.40.1
  • ghostscript-x11 >= 8.62-31.40.1
  • libgimpprint >= 4.2.7-31.40.1
  • libgimpprint-devel >= 4.2.7-31.40.1
SUSE Linux Enterprise SDK 11 GA
  • ghostscript-devel >= 8.62-32.22.2
  • ghostscript-ijs-devel >= 8.62-32.22.2
  • libgimpprint-devel >= 4.2.7-32.22.2
sles11.ia64
sled11.x86-64
sle11-sdk.s390x
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.ppc
sle11-sdk.ppc
sle11-sdk.ia64
sles11.x86-64
sle11-debuginfo.x86
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.x86-64
sled11.x86
sle11-debuginfo.s390x
SAT Patch Nr: 636
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • ghostscript-fonts-other >= 8.62-32.22.2
  • ghostscript-fonts-rus >= 8.62-32.22.2
  • ghostscript-fonts-std >= 8.62-32.22.2
  • ghostscript-library >= 8.62-32.22.2
  • ghostscript-omni >= 8.62-32.22.2
  • ghostscript-x11 >= 8.62-32.22.2
  • libgimpprint >= 4.2.7-32.22.2
sles11.ia64
sled11.x86-64
sle11-sdk.s390x
sle11-debuginfo.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.ppc
sle11-sdk.ppc
sle11-sdk.ia64
sles11.x86-64
sle11-debuginfo.x86
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.x86-64
sled11.x86
sle11-debuginfo.s390x
SAT Patch Nr: 636
SUSE Linux Enterprise SDK 10 SP2
  • ghostscript-fonts-rus >= 8.15.4-16.6
  • ghostscript-omni >= 8.15.4-16.6
  • libgimpprint-devel >= 4.2.7-62.18
sle10-sp2-sdk.ia64
sles10-sp2.ppc
sles10-sp2-debuginfo.x86
sled10-sp2.x86-64
sles10-sp2.s390x
sles10-sp2.x86-64
sles10-sp2.x86
sled10-sp2.x86
sles10-sp2-debuginfo.x86-64
sle10-sp2-sdk.x86
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.s390x
sles10-sp2.ia64
ZYPP Patch Nr: 6066
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • ghostscript-fonts-other >= 7.07.1rc1-195.14
  • ghostscript-fonts-rus >= 7.07.1rc1-195.14
  • ghostscript-fonts-std >= 7.07.1rc1-195.14
  • ghostscript-library >= 7.07.1rc1-195.14
  • ghostscript-serv >= 7.07.1rc1-195.14
  • ghostscript-x11 >= 7.07.1rc1-195.14
  • libgimpprint >= 4.2.6-46.13
  • libgimpprint-devel >= 4.2.6-46.13
sles9-nld.x86-64
sles9-oes.x86
core9.ia64
core9.x86-64
sles9-nlpos.x86
core9.x86
core9.s390x
sles9-nld.x86
core9.s390
core9.ppc
YOU Patch Nr: 12375


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA ghostscript-library Released
SUSE Linux Enterprise SDK 11 GA ghostscript-library Released
SUSE Linux Enterprise Server 11 GA ghostscript-library Released