Upstream information

CVE-2009-0583 at MITRE

Description

Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 483303 [RESOLVED / FIXED], 491897 [RESOLVED / FIXED], 492765 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ghostscript-fonts-other >= 8.62-32.27.31
  • ghostscript-fonts-rus >= 8.62-32.27.31
  • ghostscript-fonts-std >= 8.62-32.27.31
  • ghostscript-library >= 8.62-32.27.31
  • ghostscript-omni >= 8.62-32.27.31
  • ghostscript-x11 >= 8.62-32.27.31
  • libgimpprint >= 4.2.7-32.27.31
SUSE Linux Enterprise Server 11 SP2
  • ghostscript-fonts-other >= 8.62-32.28.1
  • ghostscript-fonts-rus >= 8.62-32.28.1
  • ghostscript-fonts-std >= 8.62-32.28.1
  • ghostscript-library >= 8.62-32.28.1
  • ghostscript-omni >= 8.62-32.28.1
  • ghostscript-x11 >= 8.62-32.28.1
  • libgimpprint >= 4.2.7-32.28.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • ghostscript-fonts-other >= 8.62-32.34.1
  • ghostscript-fonts-rus >= 8.62-32.34.1
  • ghostscript-fonts-std >= 8.62-32.34.1
  • ghostscript-library >= 8.62-32.34.1
  • ghostscript-omni >= 8.62-32.34.1
  • ghostscript-x11 >= 8.62-32.34.1
  • libgimpprint >= 4.2.7-32.34.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • ghostscript-fonts-other >= 8.62-32.22.2
  • ghostscript-fonts-rus >= 8.62-32.22.2
  • ghostscript-fonts-std >= 8.62-32.22.2
  • ghostscript-library >= 8.62-32.22.2
  • ghostscript-omni >= 8.62-32.22.2
  • ghostscript-x11 >= 8.62-32.22.2
  • libgimpprint >= 4.2.7-32.22.2
Patchnames:
slessp0-ghostscript-devel
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ghostscript-devel >= 8.62-32.34.1
  • ghostscript-ijs-devel >= 8.62-32.34.1
  • libgimpprint-devel >= 4.2.7-32.34.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 ghostscript-library Released
SUSE Linux Enterprise Server 11 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Released