Upstream information

CVE-2008-6679 at MITRE

Description

Buffer overflow in the BaseFont writer module in Ghostscript 8.62, and possibly other versions, allows remote attackers to cause a denial of service (ps2pdf crash) and possibly execute arbitrary code via a crafted Postscript file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 492765 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • ghostscript-fonts-other >= 8.62-32.25.1
  • ghostscript-fonts-rus >= 8.62-32.25.1
  • ghostscript-fonts-std >= 8.62-32.25.1
  • ghostscript-library >= 8.62-32.25.1
  • ghostscript-omni >= 8.62-32.25.1
  • ghostscript-x11 >= 8.62-32.25.1
  • libgimpprint >= 4.2.7-32.25.1
Patchnames:
slessp0-ghostscript-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 ghostscript-library Released
SUSE Linux Enterprise Server 11 ghostscript-library Released
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Released