Upstream information

CVE-2008-4456 at MITRE

Description

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 497546 [RESOLVED / FIXED], 604528 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libmysqlclient15 >= 5.0.67-13.20.1
  • libmysqlclient15-32bit >= 5.0.67-13.20.1
  • libmysqlclient15-x86 >= 5.0.67-13.20.1
  • libmysqlclient_r15 >= 5.0.67-13.20.1
  • mysql >= 5.0.67-13.20.1
  • mysql-Max >= 5.0.67-13.20.1
  • mysql-client >= 5.0.67-13.20.1
SUSE Linux Enterprise Server 11 SP2
  • libmysqlclient15 >= 5.0.94-0.2.4.1
  • libmysqlclient15-32bit >= 5.0.94-0.2.4.1
  • libmysqlclient15-x86 >= 5.0.94-0.2.4.1
  • libmysqlclient_r15 >= 5.0.94-0.2.4.1
  • mysql >= 5.0.94-0.2.4.1
  • mysql-Max >= 5.0.94-0.2.4.1
  • mysql-client >= 5.0.94-0.2.4.1
  • mysql-tools >= 5.0.94-0.2.4.1
SUSE Linux Enterprise Server 11 SP3
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • mysql >= 5.5.31-0.7.10
  • mysql-client >= 5.5.31-0.7.10
  • mysql-tools >= 5.5.31-0.7.10
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient15 >= 5.0.96-0.6.20
  • libmysqlclient15-32bit >= 5.0.96-0.6.20
  • libmysqlclient15-x86 >= 5.0.96-0.6.20
  • libmysqlclient_r15 >= 5.0.96-0.6.20
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
SUSE Linux Enterprise Server 11
  • libmysqlclient15 >= 5.0.67-13.16.1
  • libmysqlclient15-32bit >= 5.0.67-13.26.1
  • libmysqlclient15-x86 >= 5.0.67-13.26.1
  • libmysqlclient_r15 >= 5.0.67-13.16.1
  • mysql >= 5.0.67-13.16.1
  • mysql-Max >= 5.0.67-13.16.1
  • mysql-client >= 5.0.67-13.16.1
Patchnames:
slessp0-libmysqlclient-devel
SUSE Linux Enterprise Server for SAP Applications 11
  • libmysqlclient15 >= 5.0.67-13.16.1
  • libmysqlclient15-32bit >= 5.0.67-13.16.1
  • libmysqlclient15-x86 >= 5.0.67-13.26.1
  • libmysqlclient_r15 >= 5.0.67-13.16.1
  • mysql >= 5.0.67-13.16.1
  • mysql-Max >= 5.0.67-13.16.1
  • mysql-client >= 5.0.67-13.16.1
Patchnames:
slessp0-libmysqlclient-devel
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 mysql Released
SUSE Linux Enterprise Software Development Kit 11 mysql Released