Upstream information

CVE-2008-2327 at MITRE

Description

Multiple buffer underflows in the (1) LZWDecode, (2) LZWDecodeCompat, and (3) LZWDecodeVector functions in tif_lzw.c in the LZW decoder in LibTIFF 3.8.2 and earlier allow context-dependent attackers to execute arbitrary code via a crafted TIFF file, related to improper handling of the CODE_CLEAR code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 414946 [RESOLVED / FIXED], 518698 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libtiff-devel >= 3.8.2-141.154.1
  • libtiff-devel-32bit >= 3.8.2-141.154.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libtiff-devel-3.8.2-141.154.1
SUSE Linux Enterprise Server 11 SP1
  • libtiff3 >= 3.8.2-141.8.1
  • libtiff3-32bit >= 3.8.2-141.8.1
  • libtiff3-x86 >= 3.8.2-141.8.1
  • tiff >= 3.8.2-141.8.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libtiff3-3.8.2-141.8.1
SUSE Linux Enterprise Server 11 SP2
  • libtiff3 >= 3.8.2-141.142.1
  • libtiff3-32bit >= 3.8.2-141.142.1
  • libtiff3-x86 >= 3.8.2-141.142.1
  • tiff >= 3.8.2-141.142.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libtiff3-3.8.2-141.142.1
SUSE Linux Enterprise Server 11 SP3
  • libtiff3 >= 3.8.2-141.152.1
  • libtiff3-32bit >= 3.8.2-141.152.1
  • libtiff3-x86 >= 3.8.2-141.152.1
  • tiff >= 3.8.2-141.152.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libtiff3-3.8.2-141.152.1
SUSE Linux Enterprise Server 11 SP4
  • libtiff-devel >= 3.8.2-141.154.1
  • libtiff-devel-32bit >= 3.8.2-141.154.1
  • libtiff3 >= 3.8.2-141.154.1
  • libtiff3-32bit >= 3.8.2-141.154.1
  • libtiff3-x86 >= 3.8.2-141.154.1
  • tiff >= 3.8.2-141.154.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libtiff3-3.8.2-141.154.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libtiff-devel-3.8.2-141.154.1
openSUSE Tumbleweed
  • libtiff-devel >= 4.3.0-1.3
  • libtiff-devel-32bit >= 4.3.0-1.3
  • libtiff5 >= 4.3.0-1.3
  • libtiff5-32bit >= 4.3.0-1.3
  • tiff >= 4.3.0-1.3
Patchnames:
openSUSE Tumbleweed GA libtiff-devel-32bit-4.3.0-1.3