Upstream information

CVE-2007-6746 at MITRE

Description

telepathy-idle before 0.1.15 does not verify (1) that the issuer is a trusted CA, (2) that the server hostname matches a domain name in the subject's Common Name (CN), or (3) the expiration date of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 817120 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP2
  • telepathy-idle >= 0.1.5-1.5.1
Patchnames:
sledsp2-telepathy-idle
SUSE Linux Enterprise Desktop 11 SP3
  • telepathy-idle >= 0.1.5-1.5.1
Patchnames:
sledsp3-telepathy-idle
SUSE Linux Enterprise Desktop 12 SP1
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Workstation Extension 12 SP1 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Desktop 12 SP2
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Workstation Extension 12 SP2 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Desktop 12 SP3
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Workstation Extension 12 SP3 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Desktop 12 SP4
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Workstation Extension 12 SP4 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Desktop 12
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Desktop 12 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Workstation Extension 12 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP1
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP2
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP3
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP4
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Workstation Extension 12 SP5
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA telepathy-idle-0.2.0-1.62
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Workstation Extension 12
  • telepathy-idle >= 0.2.0-1.62
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA telepathy-idle-0.2.0-1.62
openSUSE Leap 15.0
  • telepathy-idle >= 0.2.0-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA telepathy-idle-0.2.0-lp150.2.1
openSUSE Leap 15.2
  • telepathy-idle >= 0.2.0-lp152.4.8
Patchnames:
openSUSE Leap 15.2 GA telepathy-idle-0.2.0-lp152.4.3
openSUSE Leap 15.3
  • telepathy-idle >= 0.2.0-bp153.1.14
Patchnames:
openSUSE Leap 15.3 GA telepathy-idle-0.2.0-bp153.1.14
openSUSE Leap 15.4
  • telepathy-idle >= 0.2.2-bp154.1.40
Patchnames:
openSUSE Leap 15.4 GA telepathy-idle-0.2.2-bp154.1.40
openSUSE Tumbleweed
  • telepathy-idle >= 0.2.0-3.8
Patchnames:
openSUSE Tumbleweed GA telepathy-idle-0.2.0-3.8


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP2 telepathy-idle Released
SUSE Linux Enterprise Desktop 11 SP3 telepathy-idle Released


SUSE Timeline for this CVE

CVE page created: Thu Jun 27 19:15:52 2013
CVE page last modified: Mon Jan 16 16:47:35 2023