Upstream information

CVE-2007-6601 at MITRE

Description

The DBLink module in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, 7.4 before 7.4.19, and 7.3 before 7.3.21, when local trust or ident authentication is used, allows remote attackers to gain privileges via unspecified vectors. NOTE: this issue exists because of an incomplete fix for CVE-2007-3278.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 328403 [RESOLVED / FIXED], 329282 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql-devel >= 8.3.23-0.4.1
  • postgresql94-devel >= 9.4.4-0.6.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql-devel-8.3.23-0.4.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql94-devel-9.4.4-0.6.2
SUSE Linux Enterprise Server 11 SP1
  • postgresql >= 8.3.9-0.1.1
  • postgresql-contrib >= 8.3.9-0.1.1
  • postgresql-docs >= 8.3.9-0.1.1
  • postgresql-libs >= 8.3.9-0.1.1
  • postgresql-libs-32bit >= 8.3.9-0.1.1
  • postgresql-libs-x86 >= 8.3.9-0.1.1
  • postgresql-server >= 8.3.9-0.1.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA postgresql-8.3.9-0.1.1
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.14-0.2.1
  • postgresql-contrib >= 8.3.14-0.2.1
  • postgresql-docs >= 8.3.14-0.2.1
  • postgresql-libs >= 8.3.14-0.2.1
  • postgresql-libs-32bit >= 8.3.14-0.2.1
  • postgresql-libs-x86 >= 8.3.14-0.2.1
  • postgresql-server >= 8.3.14-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA postgresql-8.3.14-0.2.1
SUSE Linux Enterprise Server 11 SP3
  • libecpg6 >= 9.1.9-0.3.1
  • libpq5 >= 9.1.9-0.3.1
  • libpq5-32bit >= 9.1.9-0.3.1
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
  • postgresql91 >= 9.1.9-0.3.1
  • postgresql91-contrib >= 9.1.9-0.3.1
  • postgresql91-docs >= 9.1.9-0.3.1
  • postgresql91-server >= 9.1.9-0.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libecpg6-9.1.9-0.3.1
SUSE Linux Enterprise Server 11 SP3 GA postgresql-8.3.23-0.4.1
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.4-0.6.2
  • libpq5 >= 9.4.4-0.6.2
  • libpq5-32bit >= 9.4.4-0.6.2
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-devel >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
  • postgresql94 >= 9.4.4-0.6.2
  • postgresql94-contrib >= 9.4.4-0.6.2
  • postgresql94-devel >= 9.4.4-0.6.2
  • postgresql94-docs >= 9.4.4-0.6.2
  • postgresql94-server >= 9.4.4-0.6.2
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libecpg6-9.4.4-0.6.2
SUSE Linux Enterprise Server 11 SP4 GA postgresql-8.3.23-0.4.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql-devel-8.3.23-0.4.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql94-devel-9.4.4-0.6.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12-LTSS postgresql93 Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 postgresql93 Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 postgresql94 Affected
SUSE Linux Enterprise Server 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 Affected
SUSE Linux Enterprise Server 11 SP4-LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 postgresql93 Already fixed


SUSE Timeline for this CVE

CVE page created: Tue Jul 9 16:49:39 2013
CVE page last modified: Mon Jan 16 14:47:43 2023