Upstream information

CVE-2007-4352 at MITRE

Description

Array index error in the DCTStream::readProgressiveDataUnit method in xpdf/Stream.cc in Xpdf 3.02pl1, as used in poppler, teTeX, KDE, KOffice, CUPS, and other products, allows remote attackers to trigger memory corruption and execute arbitrary code via a crafted PDF file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.6
Vector AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 335637 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • cups-devel >= 1.3.9-8.46.56.1
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA cups-devel-1.3.9-8.46.56.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpoppler-devel-0.12.3-1.10.1
SUSE Linux Enterprise Server 11 SP1
  • cups >= 1.3.9-8.30.1
  • cups-client >= 1.3.9-8.30.1
  • cups-libs >= 1.3.9-8.30.1
  • cups-libs-32bit >= 1.3.9-8.30.1
  • cups-libs-x86 >= 1.3.9-8.30.1
  • libpoppler-glib4 >= 0.12.3-1.2.44
  • libpoppler-qt4-3 >= 0.12.3-1.2.44
  • libpoppler5 >= 0.12.3-1.2.44
  • poppler-tools >= 0.12.3-1.2.44
  • xpdf-tools >= 3.02-138.26.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA cups-1.3.9-8.30.1
SUSE Linux Enterprise Server 11 SP1 GA libpoppler-glib4-0.12.3-1.2.44
SUSE Linux Enterprise Server 11 SP1 GA xpdf-tools-3.02-138.26.1
SUSE Linux Enterprise Server 11 SP2
  • cups >= 1.3.9-8.44.1
  • cups-client >= 1.3.9-8.44.1
  • cups-libs >= 1.3.9-8.44.1
  • cups-libs-32bit >= 1.3.9-8.44.1
  • cups-libs-x86 >= 1.3.9-8.44.1
  • libpoppler-glib4 >= 0.12.3-1.3.1
  • libpoppler-qt4-3 >= 0.12.3-1.3.1
  • libpoppler5 >= 0.12.3-1.3.1
  • poppler-tools >= 0.12.3-1.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA cups-1.3.9-8.44.1
SUSE Linux Enterprise Server 11 SP2 GA libpoppler-glib4-0.12.3-1.3.1
SUSE Linux Enterprise Server 11 SP3
  • cups >= 1.3.9-8.46.46.1
  • cups-client >= 1.3.9-8.46.46.1
  • cups-libs >= 1.3.9-8.46.46.1
  • cups-libs-32bit >= 1.3.9-8.46.46.1
  • cups-libs-x86 >= 1.3.9-8.46.46.1
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA cups-1.3.9-8.46.46.1
SUSE Linux Enterprise Server 11 SP3 GA libpoppler-glib4-0.12.3-1.8.1
SUSE Linux Enterprise Server 11 SP4
  • cups >= 1.3.9-8.46.56.1
  • cups-client >= 1.3.9-8.46.56.1
  • cups-devel >= 1.3.9-8.46.56.1
  • cups-libs >= 1.3.9-8.46.56.1
  • cups-libs-32bit >= 1.3.9-8.46.56.1
  • cups-libs-x86 >= 1.3.9-8.46.56.1
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA cups-1.3.9-8.46.56.1
SUSE Linux Enterprise Server 11 SP4 GA libpoppler-glib4-0.12.3-1.10.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA cups-devel-1.3.9-8.46.56.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpoppler-devel-0.12.3-1.10.1
openSUSE Tumbleweed
  • cups >= 2.3.3op2-4.2
  • cups-client >= 2.3.3op2-4.2
  • cups-config >= 2.3.3op2-4.2
  • cups-ddk >= 2.3.3op2-4.2
  • cups-devel >= 2.3.3op2-4.2
  • cups-devel-32bit >= 2.3.3op2-4.2
  • libcups2 >= 2.3.3op2-4.2
  • libcups2-32bit >= 2.3.3op2-4.2
  • libcupsimage2 >= 2.3.3op2-4.2
  • libcupsimage2-32bit >= 2.3.3op2-4.2
  • libpoppler-cpp0 >= 21.08.0-1.3
  • libpoppler-cpp0-32bit >= 21.08.0-1.3
  • libpoppler-devel >= 21.08.0-1.3
  • libpoppler-glib-devel >= 21.08.0-1.3
  • libpoppler-glib8 >= 21.08.0-1.3
  • libpoppler-glib8-32bit >= 21.08.0-1.3
  • libpoppler112 >= 21.08.0-1.3
  • libpoppler112-32bit >= 21.08.0-1.3
  • poppler-tools >= 21.08.0-1.3
  • typelib-1_0-Poppler-0_18 >= 21.08.0-1.3
Patchnames:
openSUSE Tumbleweed GA cups-2.3.3op2-4.2
openSUSE Tumbleweed GA libpoppler-cpp0-21.08.0-1.3


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP6 poppler Already fixed
SUSE Linux Enterprise High Performance Computing 12 cups154 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 poppler Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 poppler Already fixed
SUSE Linux Enterprise Module for Legacy 12 cups154 Already fixed
SUSE Linux Enterprise Module for Package Hub 15 SP6 poppler Already fixed
SUSE Linux Enterprise Server 12 SP5 cups154 Already fixed
SUSE Linux Enterprise Server 15 SP6 poppler Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 cups154 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 poppler Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Server 12 cups154 Already fixed
SUSE Linux Enterprise Server 12 SP3 cups154 Already fixed
SUSE Linux Enterprise Server 12 SP4 cups154 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 cups154 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 cups154 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cups154 Already fixed


SUSE Timeline for this CVE

CVE page created: Tue Jul 9 15:53:54 2013
CVE page last modified: Wed May 22 17:10:49 2024