Upstream information

CVE-2007-2953 at MITRE

Description

Format string vulnerability in the helptags_one function in src/ex_cmds.c in Vim 6.4 and earlier, and 7.x up to 7.1, allows user-assisted remote attackers to execute arbitrary code via format string specifiers in a help-tags tag in a help file, related to the helptags command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 292433 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • gvim >= 7.2-8.8
  • vim >= 7.2-8.8
  • vim-base >= 7.2-8.8
  • vim-data >= 7.2-8.8
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA gvim-7.2-8.8
SUSE Linux Enterprise Server 11 SP2
  • gvim >= 7.2-8.15.2
  • vim >= 7.2-8.15.2
  • vim-base >= 7.2-8.15.2
  • vim-data >= 7.2-8.15.2
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA gvim-7.2-8.15.2
SUSE Linux Enterprise Server 11 SP3
  • gvim >= 7.2-8.15.2
  • vim >= 7.2-8.15.2
  • vim-base >= 7.2-8.15.2
  • vim-data >= 7.2-8.15.2
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA gvim-7.2-8.15.2
SUSE Linux Enterprise Server 11 SP4
  • gvim >= 7.2-8.15.2
  • vim >= 7.2-8.15.2
  • vim-base >= 7.2-8.15.2
  • vim-data >= 7.2-8.15.2
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gvim-7.2-8.15.2
openSUSE Tumbleweed
  • gvim >= 8.2.3408-1.2
  • vim >= 8.2.3408-1.2
  • vim-data >= 8.2.3408-1.2
  • vim-data-common >= 8.2.3408-1.2
  • vim-small >= 8.2.3408-1.2
Patchnames:
openSUSE Tumbleweed GA gvim-8.2.3408-1.2