Upstream information

CVE-2007-1995 at MITRE

Description

bgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.3
Vector AV:N/AC:M/Au:S/C:N/I:N/A:C
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 266100 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • quagga >= 0.99.15-0.14.11
  • quagga-devel >= 0.99.15-0.14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA quagga-0.99.15-0.14.11
SUSE Linux Enterprise Server 11 SP1
  • quagga >= 0.99.15-0.1.55
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA quagga-0.99.15-0.1.55
SUSE Linux Enterprise Server 11 SP2
  • quagga >= 0.99.15-0.6.2
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA quagga-0.99.15-0.6.2
SUSE Linux Enterprise Server 11 SP3
  • quagga >= 0.99.15-0.12.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA quagga-0.99.15-0.12.1
SUSE Linux Enterprise Server 11 SP4
  • quagga >= 0.99.15-0.14.11
  • quagga-devel >= 0.99.15-0.14.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA quagga-0.99.15-0.14.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA quagga-0.99.15-0.14.11
openSUSE Tumbleweed
  • libfpm_pb0 >= 1.2.4-2.14
  • libospf0 >= 1.2.4-2.14
  • libospfapiclient0 >= 1.2.4-2.14
  • libquagga_pb0 >= 1.2.4-2.14
  • libzebra1 >= 1.2.4-2.14
  • quagga >= 1.2.4-2.14
  • quagga-devel >= 1.2.4-2.14
Patchnames:
openSUSE Tumbleweed GA libfpm_pb0-1.2.4-2.14


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 quagga Already fixed
SUSE Enterprise Storage 6 quagga Already fixed
SUSE Linux Enterprise High Performance Computing 15 LTSS quagga Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS quagga Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 quagga Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 quagga Already fixed
SUSE Linux Enterprise Server 15 ESPOS quagga Already fixed
SUSE Linux Enterprise Server 15 LTSS quagga Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS quagga Already fixed
SUSE Linux Enterprise Server 15 SP2 quagga Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 quagga Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 quagga Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 quagga Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 quagga Already fixed
SUSE Linux Enterprise Storage 7 quagga Already fixed
SUSE Manager Proxy 4.0 quagga Already fixed
SUSE Manager Proxy 4.1 quagga Already fixed
SUSE Manager Retail Branch Server 4.0 quagga Already fixed
SUSE Manager Retail Branch Server 4.1 quagga Already fixed
SUSE Manager Server 4.0 quagga Already fixed
SUSE Manager Server 4.1 quagga Already fixed