Upstream information

CVE-2007-0235 at MITRE

Description

Stack-based buffer overflow in the glibtop_get_proc_map_s function in libgtop before 2.14.6 (libgtop2) allows local users to cause a denial of service (crash) and possibly execute arbitrary code via a process with a long filename that is mapped in its address space, which triggers the overflow in gnome-system-monitor.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.7
Vector AV:L/AC:H/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 235086 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgtop-2_0-7-32bit >= 2.28.0-1.13.1
  • libgtop-2_0-7-x86 >= 2.28.0-1.13.1
  • libgtop-devel >= 2.28.0-1.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libgtop-2_0-7-32bit-2.28.0-1.13.1
SUSE Linux Enterprise Server 11 SP1
  • libgtop >= 2.28.0-1.2.20
  • libgtop-2_0-7 >= 2.28.0-1.2.20
  • libgtop-doc >= 2.28.0-1.2.20
  • libgtop-lang >= 2.28.0-1.2.20
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libgtop-2.28.0-1.2.20
SUSE Linux Enterprise Server 11 SP2
  • libgtop >= 2.28.0-1.2.20
  • libgtop-2_0-7 >= 2.28.0-1.2.20
  • libgtop-doc >= 2.28.0-1.2.20
  • libgtop-lang >= 2.28.0-1.2.20
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libgtop-2.28.0-1.2.20
SUSE Linux Enterprise Server 11 SP3
  • libgtop >= 2.28.0-1.9.24
  • libgtop-2_0-7 >= 2.28.0-1.9.24
  • libgtop-doc >= 2.28.0-1.9.24
  • libgtop-lang >= 2.28.0-1.9.24
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libgtop-2.28.0-1.9.24
SUSE Linux Enterprise Server 11 SP4
  • libgtop >= 2.28.0-1.13.1
  • libgtop-2_0-7 >= 2.28.0-1.13.1
  • libgtop-2_0-7-32bit >= 2.28.0-1.13.1
  • libgtop-2_0-7-x86 >= 2.28.0-1.13.1
  • libgtop-devel >= 2.28.0-1.13.1
  • libgtop-doc >= 2.28.0-1.13.1
  • libgtop-lang >= 2.28.0-1.13.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libgtop-2.28.0-1.13.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libgtop-2_0-7-32bit-2.28.0-1.13.1
openSUSE Tumbleweed
  • libgtop >= 2.40.0-2.11
  • libgtop-2_0-11 >= 2.40.0-2.11
  • libgtop-2_0-11-32bit >= 2.40.0-2.11
  • libgtop-devel >= 2.40.0-2.11
  • libgtop-doc >= 2.40.0-2.11
  • libgtop-lang >= 2.40.0-2.11
  • typelib-1_0-GTop-2_0 >= 2.40.0-2.11
Patchnames:
openSUSE Tumbleweed GA libgtop-2.40.0-2.11