Upstream information

CVE-2006-3810 at MITRE

Description

Cross-site scripting (XSS) vulnerability in Mozilla Firefox 1.5 before 1.5.0.5, Thunderbird before 1.5.0.5, and SeaMonkey before 1.0.3 allows remote attackers to inject arbitrary web script or HTML via the XPCNativeWrapper(window).Function construct.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 195043 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
SUSE LINUX 9.2
SUSE LINUX 9.3
  • MozillaThunderbird >= 1.5.0.5-0.1
SUSE LINUX 10.1
  • MozillaThunderbird >= 1.5.0.5-0.1
  • MozillaThunderbird-translations >= 1.5.0.5-0.1
SUSE LINUX 10.0
  • MozillaFirefox >= 1.5.0.6-1.2
  • MozillaFirefox-translations >= 1.5.0.6-1.2
SUSE LINUX 10.1
  • MozillaFirefox >= 1.5.0.6-1.3
  • MozillaFirefox-translations >= 1.5.0.6-1.3
SUSE LINUX 9.2
SUSE LINUX 9.3
  • MozillaFirefox >= 1.5.0.6-1.4
  • MozillaFirefox-translations >= 1.5.0.6-1.4
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • MozillaFirefox >= 1.5.0.6-1.6
  • MozillaFirefox-translations >= 1.5.0.6-1.6
Builds
YOU Patch Nr: 11157
SUSE LINUX 10.1
  • seamonkey >= 1.0.4-2.1
  • seamonkey-calendar >= 1.0.4-2.1
  • seamonkey-dom-inspector >= 1.0.4-2.1
  • seamonkey-irc >= 1.0.4-2.1
  • seamonkey-mail >= 1.0.4-2.1
  • seamonkey-spellchecker >= 1.0.4-2.1
  • seamonkey-venkman >= 1.0.4-2.1