Upstream information

CVE-2006-3694 at MITRE

Description

Multiple unspecified vulnerabilities in Ruby before 1.8.5 allow remote attackers to bypass "safe level" checks via unspecified vectors involving (1) the alias function and (2) "directory operations".

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 193661 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel-1.8.7.p357-0.9.17.1
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.24.2
  • ruby-doc-html >= 1.8.7.p72-5.24.2
  • ruby-tk >= 1.8.7.p72-5.24.2
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ruby-1.8.7.p72-5.24.2
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ruby-1.8.7.p357-0.7.1
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ruby-1.8.7.p357-0.9.9.1
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ruby-1.8.7.p357-0.9.17.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel-1.8.7.p357-0.9.17.1