Upstream information

CVE-2006-3376 at MITRE

Description

Integer overflow in player.c in libwmf 0.2.8.4, as used in multiple products including (1) wv, (2) abiword, (3) freetype, (4) gimp, (5) libgsf, and (6) imagemagick allows remote attackers to execute arbitrary code via the MaxRecordSize header field in a WMF file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 189924 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwmf >= 0.2.8.4-206.27.4
  • libwmf-32bit >= 0.2.8.4-206.27.4
  • libwmf-devel >= 0.2.8.4-206.27.4
  • libwmf-gnome >= 0.2.8.4-206.27.4
  • libwmf-gnome-32bit >= 0.2.8.4-206.27.4
  • libwmf-gnome-x86 >= 0.2.8.4-206.27.4
  • libwmf-x86 >= 0.2.8.4-206.27.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libwmf-0.2.8.4-206.27.4
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libwmf-0_2-7 >= 0.2.12-150000.4.4.1
  • libwmf-devel >= 0.2.12-150000.4.4.1
  • libwmf-gnome >= 0.2.12-150000.4.4.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP4 GA libwmf-0_2-7-0.2.12-150000.4.4.1
openSUSE Leap 15.4
  • libwmf-0_2-7 >= 0.2.12-150000.4.4.1
Patchnames:
openSUSE Leap 15.4 GA libwmf-0_2-7-0.2.12-150000.4.4.1
openSUSE Tumbleweed
  • >=
Patchnames:
openSUSE-Tumbleweed-2024:11012


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 libwmf Not affected
SUSE Linux Enterprise Desktop 15 SP6 libwmf Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 libwmf Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP6 libwmf Not affected
SUSE Linux Enterprise Server 12 SP5 libwmf Not affected
SUSE Linux Enterprise Server 15 SP5 libwmf Not affected
SUSE Linux Enterprise Server 15 SP6 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP5 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP6 libwmf Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libwmf Not affected
SUSE Linux Enterprise Server 15 SP2 libwmf Not affected
SUSE Linux Enterprise Server 15 SP3 libwmf Not affected
SUSE Linux Enterprise Server 15 SP4 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libwmf Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 libwmf Not affected
SUSE Linux Enterprise Desktop 12 SP1 libwmf Not affected
SUSE Linux Enterprise Desktop 12 SP2 libwmf Not affected
SUSE Linux Enterprise Desktop 12 SP3 libwmf Not affected
SUSE Linux Enterprise Desktop 12 SP4 libwmf Not affected
SUSE Linux Enterprise Desktop 15 libwmf Not affected
SUSE Linux Enterprise Desktop 15 SP1 libwmf Not affected
SUSE Linux Enterprise Desktop 15 SP2 libwmf Not affected
SUSE Linux Enterprise Desktop 15 SP3 libwmf Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 libwmf Not affected
SUSE Linux Enterprise Server 12 libwmf Not affected
SUSE Linux Enterprise Server 12 SP1 libwmf Not affected
SUSE Linux Enterprise Server 12 SP2 libwmf Not affected
SUSE Linux Enterprise Server 12 SP3 libwmf Not affected
SUSE Linux Enterprise Server 12 SP4 libwmf Not affected
SUSE Linux Enterprise Server 15 libwmf Not affected
SUSE Linux Enterprise Server 15 SP1 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libwmf Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libwmf Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP1 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP2 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP3 libwmf Not affected
SUSE Linux Enterprise Workstation Extension 15 SP4 libwmf Not affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 03:38:25 2013
CVE page last modified: Sat Jun 15 17:36:02 2024