Upstream information

CVE-2006-3125 at MITRE

Description

Array index error in tetrinet.c in gtetrinet 0.7.8 and earlier allows remote attackers to execute arbitrary code via a packet specifying a negative number of players, which is used as an array index.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 199665 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • gtetrinet >= 0.7.5-144.2
SUSE LINUX 10.1
  • gtetrinet >= 0.7.9-16.2
SUSE LINUX 9.2
  • gtetrinet >= 0.7.5-138.2
SUSE LINUX 9.3
  • gtetrinet >= 0.7.5-142.2