Upstream information

CVE-2006-0019 at MITRE

Description

Heap-based buffer overflow in the encodeURI and decodeURI functions in the kjs JavaScript interpreter engine in KDE 3.2.0 through 3.5.0 allows remote attackers to execute arbitrary code via a crafted, UTF-8 encoded URI.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 142319 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • kdelibs3 >= 3.4.2-24.2
  • kdelibs3-32bit >= 3.4.2-24.2
  • kdelibs3-64bit >= 3.4.2-24.2
  • kdelibs3-devel >= 3.4.2-24.2
SUSE LINUX 9.1 for IA32
  • kdelibs3 >= 3.2.1-44.65
  • kdelibs3-devel >= 3.2.1-44.65
SUSE LINUX 9.1 for x86-64
  • kdelibs3 >= 3.2.1-44.65
  • kdelibs3-32bit >= 9.1-200601130425
  • kdelibs3-devel >= 3.2.1-44.65
SUSE LINUX 9.2
  • kdelibs3 >= 3.3.0-34.11
  • kdelibs3-32bit >= 9.2-200601131140
  • kdelibs3-devel >= 3.3.0-34.11
SUSE LINUX 9.3
  • kdelibs3 >= 3.4.0-20.10
  • kdelibs3-32bit >= 9.3-7.4
  • kdelibs3-devel >= 3.4.0-20.10
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • kdelibs3 >= 3.2.1-44.65
  • kdelibs3-devel >= 3.2.1-44.65
suse91.s390
suse91.ppc
suse91.x86-64
sles9-oes.x86
suse91.ia64
YOU Patch Nr: 10822
Novell Linux Desktop 9 for x86_64
  • kdelibs3 >= 3.2.1-44.65
  • kdelibs3-32bit >= 9-200601130434
  • kdelibs3-devel >= 3.2.1-44.65
suse91.s390
suse91.ppc
suse91.x86-64
sles9-oes.x86
suse91.ia64
YOU Patch Nr: 10822