Upstream information

CVE-2005-1409 at MITRE

Description

PostgreSQL 7.3.x through 8.0.x gives public EXECUTE access to certain character conversion functions, which allows unprivileged users to call those functions with malicious values, with unknown impact, aka the "Character conversion vulnerability."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 81678, 82869 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
suse91.s390
suse91.ia64
suse91.x86
suse91.ppc
YOU Patch Nr: 10230
SUSE LINUX 9.1 for IA32
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
SUSE LINUX 9.1 for x86-64
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-libs-32bit >= 9.1-200506061950
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
SUSE LINUX 9.2
  • postgresql >= 7.4.8-0.3
  • postgresql-contrib >= 7.4.8-0.3
  • postgresql-devel >= 7.4.8-0.3
  • postgresql-docs >= 7.4.8-0.3
  • postgresql-libs >= 7.4.8-0.3
  • postgresql-libs-32bit >= 9.2-200506062019
  • postgresql-pl >= 7.4.8-0.3
  • postgresql-server >= 7.4.8-0.3
SUSE LINUX 9.3
  • postgresql >= 8.0.3-1.2
  • postgresql-contrib >= 8.0.3-1.2
  • postgresql-devel >= 8.0.3-1.2
  • postgresql-docs >= 8.0.3-1.2
  • postgresql-libs >= 8.0.3-1.2
  • postgresql-libs-32bit >= 9.3-7.2
  • postgresql-pl >= 8.0.3-1.2
  • postgresql-server >= 8.0.3-1.2