Upstream information

CVE-2014-8962 at MITRE

Description

Stack-based buffer overflow in stream_decoder.c in libFLAC before 1.3.1 allows remote attackers to execute arbitrary code via a crafted .flac file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 906831 [RESOLVED / FIXED], 907764 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libFLAC++6 >= 1.2.1-68.17.1
  • libFLAC8 >= 1.2.1-68.17.1
  • libFLAC8-32bit >= 1.2.1-68.17.1
Patchnames:
sledsp3-flac
SUSE Linux Enterprise Desktop 12 SP1
  • libFLAC8 >= 1.3.0-6.1
  • libFLAC8-32bit >= 1.3.0-6.1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
  • libFLAC++6 >= 1.3.0-11.1
  • libFLAC++6-32bit >= 1.3.0-11.1
  • libFLAC8 >= 1.3.0-11.1
  • libFLAC8-32bit >= 1.3.0-11.1
SUSE Linux Enterprise Desktop 12
  • libFLAC8 >= 1.3.0-6.1
  • libFLAC8-32bit >= 1.3.0-6.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-115
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libFLAC++6 >= 1.3.0-11.1
  • libFLAC8 >= 1.3.0-11.1
  • libFLAC8-32bit >= 1.3.0-11.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • flac-devel >= 1.3.2-3.3.20
  • libFLAC++6 >= 1.3.2-3.3.20
  • libFLAC8 >= 1.3.2-3.3.20
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • flac-devel >= 1.3.2-3.6.1
  • libFLAC++6 >= 1.3.2-3.6.1
  • libFLAC8 >= 1.3.2-3.6.1
SUSE Linux Enterprise Module for Basesystem 15
  • flac-devel >= 1.3.2-1.29
  • libFLAC++6 >= 1.3.2-1.29
  • libFLAC8 >= 1.3.2-1.29
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • flac >= 1.3.2-3.3.20
  • libFLAC8-32bit >= 1.3.2-3.3.20
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP3
  • flac >= 1.3.2-3.6.1
  • libFLAC8-32bit >= 1.3.2-3.6.1
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libFLAC++6 >= 1.2.1-68.17.1
  • libFLAC8 >= 1.2.1-68.17.1
  • libFLAC8-32bit >= 1.2.1-68.17.1
  • libFLAC8-x86 >= 1.2.1-68.17.1
Patchnames:
slessp3-flac
SUSE Linux Enterprise Server 11 SP4
  • libFLAC++6 >= 1.2.1-68.17.1
  • libFLAC8 >= 1.2.1-68.17.1
  • libFLAC8-32bit >= 1.2.1-68.17.1
  • libFLAC8-x86 >= 1.2.1-68.17.1
SUSE Linux Enterprise Server 12 SP1
  • libFLAC++6 >= 1.3.0-6.1
  • libFLAC8 >= 1.3.0-6.1
  • libFLAC8-32bit >= 1.3.0-6.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • libFLAC++6 >= 1.3.0-6.1
  • libFLAC8 >= 1.3.0-6.1
  • libFLAC8-32bit >= 1.3.0-6.1
Patchnames:
SUSE-SLE-SERVER-12-2014-115
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libFLAC++6 >= 1.3.0-11.1
  • libFLAC8 >= 1.3.0-11.1
SUSE Linux Enterprise Software Development Kit 11 SP3
  • flac-devel >= 1.2.1-68.17.1
  • libFLAC++6-32bit >= 1.2.1-68.17.1
  • libFLAC++6-x86 >= 1.2.1-68.17.1
Patchnames:
sdksp3-flac
SUSE Linux Enterprise Software Development Kit 11 SP4
  • flac-devel >= 1.2.1-68.17.1
  • libFLAC++6-32bit >= 1.2.1-68.17.1
  • libFLAC++6-x86 >= 1.2.1-68.17.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • flac-devel >= 1.3.0-6.1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • flac-devel >= 1.3.0-11.1
SUSE Linux Enterprise Software Development Kit 12
  • flac-devel >= 1.3.0-6.1
Patchnames:
SUSE-SLE-SDK-12-2014-115
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libFLAC++6-32bit >= 1.3.0-11.1
openSUSE Leap 15.0
  • libFLAC++6 >= 1.3.2-lp150.1.11
  • libFLAC8 >= 1.3.2-lp150.1.11
Patchnames:
openSUSE Leap 15.0 GA libFLAC++6
openSUSE Tumbleweed
  • flac >= 1.3.1-3.1
  • flac-devel >= 1.3.1-3.1
  • flac-devel-32bit >= 1.3.1-3.1
  • flac-doc >= 1.3.1-3.1
  • libFLAC++6 >= 1.3.1-3.1
  • libFLAC++6-32bit >= 1.3.1-3.1
  • libFLAC8 >= 1.3.1-3.1
  • libFLAC8-32bit >= 1.3.1-3.1
Patchnames:
openSUSE Tumbleweed GA flac


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 flac Released
HPE Helion OpenStack 8 openvpn Released
SLES for SAP Applications openvpn Released
SUSE CaaS Platform 4.0 openvpn Already fixed
SUSE Enterprise Storage 5 flac Released
SUSE Enterprise Storage 5 openvpn Released
SUSE Enterprise Storage 6 openvpn Already fixed
SUSE Linux Enterprise Desktop 11 SP1 openvpn Released
SUSE Linux Enterprise Desktop 11 SP3 openvpn Released
SUSE Linux Enterprise Desktop 11 SP4 openvpn Released
SUSE Linux Enterprise Desktop 12 openvpn Released
SUSE Linux Enterprise Desktop 12 SP1 openvpn Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search openvpn Released
SUSE Linux Enterprise High Performance Computing 12 SP5 flac Released
SUSE Linux Enterprise High Performance Computing 12 SP5 openvpn Released
SUSE Linux Enterprise High Performance Computing 15 LTSS openvpn Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openvpn Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 openvpn Already fixed
SUSE Linux Enterprise Point of Service Image Server 12 flac Released
SUSE Linux Enterprise Point of Service Image Server 12 openvpn Released
SUSE Linux Enterprise Server 11 SP1 openvpn Released
SUSE Linux Enterprise Server 11 SP1 LTSS openvpn Released
SUSE Linux Enterprise Server 11 SP2 LTSS openvpn Released
SUSE Linux Enterprise Server 11 SP3 openvpn Released
SUSE Linux Enterprise Server 11 SP3 LTSS openvpn Released
SUSE Linux Enterprise Server 11 SP3 for VMware openvpn Released
SUSE Linux Enterprise Server 11 SP4 openvpn Released
SUSE Linux Enterprise Server 11 SP4 LTSS openvpn Released
SUSE Linux Enterprise Server 12 openvpn Released
SUSE Linux Enterprise Server 12 SP2 BCL flac Released
SUSE Linux Enterprise Server 12 SP2 BCL openvpn Released
SUSE Linux Enterprise Server 12 SP2 ESPOS flac Released
SUSE Linux Enterprise Server 12 SP2 ESPOS openvpn Released
SUSE Linux Enterprise Server 12 SP2 LTSS flac Released
SUSE Linux Enterprise Server 12 SP2 LTSS openvpn Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON flac Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON openvpn Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP flac Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP openvpn Released
SUSE Linux Enterprise Server 12 SP3 BCL flac Released
SUSE Linux Enterprise Server 12 SP3 BCL openvpn Released
SUSE Linux Enterprise Server 12 SP3 ESPOS flac Released
SUSE Linux Enterprise Server 12 SP3 ESPOS openvpn Released
SUSE Linux Enterprise Server 12 SP3 LTSS flac Released
SUSE Linux Enterprise Server 12 SP3 LTSS openvpn Released
SUSE Linux Enterprise Server 12 SP4 ESPOS flac Released
SUSE Linux Enterprise Server 12 SP4 ESPOS openvpn Released
SUSE Linux Enterprise Server 12 SP4 LTSS flac Released
SUSE Linux Enterprise Server 12 SP4 LTSS openvpn Released
SUSE Linux Enterprise Server 12 SP5 flac Released
SUSE Linux Enterprise Server 12 SP5 openvpn Released
SUSE Linux Enterprise Server 15 LTSS openvpn Already fixed
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux openvpn Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS openvpn Already fixed
SUSE Linux Enterprise Server ESPOS 15 openvpn Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 flac Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openvpn Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 flac Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openvpn Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 flac Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openvpn Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 flac Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openvpn Released
SUSE Linux Enterprise Server for SAP Applications 15 openvpn Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openvpn Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One openvpn Released
SUSE Linux Enterprise Software Development Kit 12 SP5 flac Released
SUSE Linux Enterprise Workstation Extension 12 flac Released
SUSE Manager Proxy 4.0 openvpn Already fixed
SUSE Manager Retail Branch Server 4.0 openvpn Already fixed
SUSE Manager Server 4.0 openvpn Already fixed
SUSE OpenStack Cloud 7 flac Released
SUSE OpenStack Cloud 7 openvpn Released
SUSE OpenStack Cloud 8 flac Released
SUSE OpenStack Cloud 8 openvpn Released
SUSE OpenStack Cloud 9 flac Released
SUSE OpenStack Cloud 9 openvpn Released
SUSE OpenStack Cloud Crowbar 8 flac Released
SUSE OpenStack Cloud Crowbar 8 openvpn Released
SUSE OpenStack Cloud Crowbar 9 flac Released
SUSE OpenStack Cloud Crowbar 9 openvpn Released