Upstream information

CVE-2018-18873 at MITRE

Description

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function ras_putdatastd in ras/ras_enc.c.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entries: 1114495 [IN_PROGRESS], 1114498 [IN_PROGRESS], 1178702 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • jasper >= 2.0.14-3.16.1
  • libjasper4 >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-2689
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • jasper >= 2.0.14-3.16.1
  • libjasper4 >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-2689
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • jasper >= 2.0.14-3.16.1
  • libjasper-devel >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-2689
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • jasper >= 2.0.14-3.16.1
  • libjasper-devel >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2020-2689
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • jasper >= 2.0.14-3.16.1
  • libjasper4-32bit >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-2689
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • jasper >= 2.0.14-3.16.1
  • libjasper4-32bit >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-2689
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP1
  • jasper >= 2.0.14-3.16.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-2689
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • jasper >= 1.900.14-195.22.1
  • libjasper1 >= 1.900.14-195.22.1
  • libjasper1-32bit >= 1.900.14-195.22.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-2690
SUSE Linux Enterprise Software Development Kit 12 SP5
  • jasper >= 1.900.14-195.22.1
  • libjasper-devel >= 1.900.14-195.22.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-2690
openSUSE Leap 15.1
  • jasper >= 2.0.14-lp151.4.9.1
  • jasper-debuginfo >= 2.0.14-lp151.4.9.1
  • jasper-debugsource >= 2.0.14-lp151.4.9.1
  • libjasper-devel >= 2.0.14-lp151.4.9.1
  • libjasper4 >= 2.0.14-lp151.4.9.1
  • libjasper4-32bit >= 2.0.14-lp151.4.9.1
  • libjasper4-32bit-debuginfo >= 2.0.14-lp151.4.9.1
  • libjasper4-debuginfo >= 2.0.14-lp151.4.9.1
Patchnames:
openSUSE-2020-1517
openSUSE Leap 15.2
  • jasper >= 2.0.14-lp152.7.3.1
  • jasper-debuginfo >= 2.0.14-lp152.7.3.1
  • jasper-debugsource >= 2.0.14-lp152.7.3.1
  • libjasper-devel >= 2.0.14-lp152.7.3.1
  • libjasper4 >= 2.0.14-lp152.7.3.1
  • libjasper4-32bit >= 2.0.14-lp152.7.3.1
  • libjasper4-32bit-debuginfo >= 2.0.14-lp152.7.3.1
  • libjasper4-debuginfo >= 2.0.14-lp152.7.3.1
Patchnames:
openSUSE-2020-1523


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications ghostscript-library Affected
SLES for SAP Applications jasper Affected
SUSE CaaS Platform 4.0 jasper Released
SUSE Enterprise Storage 6 jasper Released
SUSE Linux Enterprise 15 Module for Basesystem jasper Affected
SUSE Linux Enterprise 15 Module for Desktop Applications jasper Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem jasper Released
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications jasper Released
SUSE Linux Enterprise 15-SP2 Module for Basesystem jasper Released
SUSE Linux Enterprise 15-SP2 Module for Desktop Applications jasper Released
SUSE Linux Enterprise Desktop 12 SP3 jasper Affected
SUSE Linux Enterprise Desktop 12 SP4 jasper Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 jasper Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 jasper Released
SUSE Linux Enterprise High Performance Computing 15 LTSS jasper Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS jasper Released
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 LTSS jasper Affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 jasper Affected
SUSE Linux Enterprise Server 12 LTSS jasper Affected
SUSE Linux Enterprise Server 12 SP1 LTSS jasper Affected
SUSE Linux Enterprise Server 12 SP2 LTSS jasper Affected
SUSE Linux Enterprise Server 12 SP3 jasper Affected
SUSE Linux Enterprise Server 12 SP4 jasper Affected
SUSE Linux Enterprise Server 12 SP5 jasper Released
SUSE Linux Enterprise Server 15 LTSS jasper Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux jasper Released
SUSE Linux Enterprise Server 15 SP1 LTSS jasper Released
SUSE Linux Enterprise Server ESPOS 15 jasper Released
SUSE Linux Enterprise Server for SAP Applications 12 jasper Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 jasper Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 jasper Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 jasper Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Applications 15 jasper Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 jasper Released
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 jasper Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 jasper Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 jasper Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 jasper In progress
SUSE Manager Proxy 4.0 jasper Released
SUSE Manager Retail Branch Server 4.0 jasper Released
SUSE Manager Server 4.0 jasper Released
SUSE Package Hub 15 jasper Released