Upstream information

CVE-2018-1000876 at MITRE

Description

binutils version 2.32 and earlier contains a Integer Overflow vulnerability in objdump, bfd_get_dynamic_reloc_upper_bound,bfd_canonicalize_dynamic_reloc that can result in Integer overflow trigger heap overflow. Successful exploitation allows execution of arbitrary code.. This attack appear to be exploitable via Local. This vulnerability appears to have been fixed in after commit 3a551c7a1b80fca579461774860574eabfd7f18f.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.3
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1120640 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4.5/cilium:1.7.6
Container caasp/v4/cilium:1.6.6
Image caasp4/caasp-cilium-image
Image caasp45/caasp-cilium-image
  • binutils >= 2.32-7.5.1
HPE Helion Openstack 8
  • binutils >= 2.32-9.33.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2650
SUSE Enterprise Storage 4
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-Storage-4-2019-2650
SUSE Enterprise Storage 5
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-Storage-5-2019-2650
SUSE Linux Enterprise Desktop 12 SP4
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2650
SUSE Linux Enterprise High Performance Computing 12 SP5
  • binutils >= 2.32-9.36.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • binutils >= 2.32-7.5.1
  • binutils-devel >= 2.32-7.5.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2779
SUSE Linux Enterprise Module for Basesystem 15
  • binutils >= 2.32-6.8.1
  • binutils-devel >= 2.32-6.8.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2780
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • binutils >= 2.32-7.5.1
  • binutils-devel-32bit >= 2.32-7.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2019-2779
SUSE Linux Enterprise Module for Development Tools 15
  • binutils >= 2.32-6.8.1
  • binutils-devel-32bit >= 2.32-6.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-2780
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • binutils >= 2.32-7.5.1
  • binutils-gold >= 2.32-7.5.1
  • cross-aarch64-binutils >= 2.32-7.5.1
  • cross-arm-binutils >= 2.32-7.5.1
  • cross-avr-binutils >= 2.32-7.5.1
  • cross-epiphany-binutils >= 2.32-7.5.1
  • cross-hppa-binutils >= 2.32-7.5.1
  • cross-hppa64-binutils >= 2.32-7.5.1
  • cross-i386-binutils >= 2.32-7.5.1
  • cross-ia64-binutils >= 2.32-7.5.1
  • cross-m68k-binutils >= 2.32-7.5.1
  • cross-mips-binutils >= 2.32-7.5.1
  • cross-ppc-binutils >= 2.32-7.5.1
  • cross-ppc64-binutils >= 2.32-7.5.1
  • cross-ppc64le-binutils >= 2.32-7.5.1
  • cross-riscv64-binutils >= 2.32-7.5.1
  • cross-rx-binutils >= 2.32-7.5.1
  • cross-s390-binutils >= 2.32-7.5.1
  • cross-s390x-binutils >= 2.32-7.5.1
  • cross-sparc-binutils >= 2.32-7.5.1
  • cross-sparc64-binutils >= 2.32-7.5.1
  • cross-spu-binutils >= 2.32-7.5.1
  • cross-x86_64-binutils >= 2.32-7.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2779
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • binutils >= 2.32-6.8.1
  • binutils-gold >= 2.32-6.8.1
  • cross-arm-binutils >= 2.32-6.8.1
  • cross-avr-binutils >= 2.32-6.8.1
  • cross-epiphany-binutils >= 2.32-6.8.1
  • cross-hppa-binutils >= 2.32-6.8.1
  • cross-hppa64-binutils >= 2.32-6.8.1
  • cross-i386-binutils >= 2.32-6.8.1
  • cross-ia64-binutils >= 2.32-6.8.1
  • cross-m68k-binutils >= 2.32-6.8.1
  • cross-mips-binutils >= 2.32-6.8.1
  • cross-ppc-binutils >= 2.32-6.8.1
  • cross-ppc64-binutils >= 2.32-6.8.1
  • cross-riscv64-binutils >= 2.32-6.8.1
  • cross-rx-binutils >= 2.32-6.8.1
  • cross-s390-binutils >= 2.32-6.8.1
  • cross-sparc-binutils >= 2.32-6.8.1
  • cross-sparc64-binutils >= 2.32-6.8.1
  • cross-spu-binutils >= 2.32-6.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2780
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP1
  • binutils >= 2.32-7.5.1
  • binutils-gold >= 2.32-7.5.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2019-2779
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • binutils >= 2.32-6.8.1
  • binutils-gold >= 2.32-6.8.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-2780
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2650
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2650
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2650
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2650
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2650
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2650
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2650
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2650
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2650
SUSE Linux Enterprise Server 12 SP5
  • binutils >= 2.32-9.36.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2650
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2650
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2650
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2650
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2650
SUSE Linux Enterprise Software Development Kit 12 SP4
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
  • binutils-gold >= 2.32-9.33.1
  • cross-ppc-binutils >= 2.32-9.33.1
  • cross-spu-binutils >= 2.32-9.33.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2650
SUSE Linux Enterprise Software Development Kit 12 SP5
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.36.1
  • binutils-gold >= 2.32-9.36.1
  • cross-ppc-binutils >= 2.32-9.36.1
  • cross-spu-binutils >= 2.32-9.36.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2650
SUSE OpenStack Cloud 7
  • binutils >= 2.32-9.33.1
  • binutils-devel >= 2.32-9.33.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2650
SUSE OpenStack Cloud 8
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2650
SUSE OpenStack Cloud Crowbar 8
  • binutils >= 2.32-9.33.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2650
openSUSE Leap 15.0
  • binutils >= 2.32-lp150.10.1
  • binutils-debuginfo >= 2.32-lp150.10.1
  • binutils-debugsource >= 2.32-lp150.10.1
  • binutils-devel >= 2.32-lp150.10.1
  • binutils-devel-32bit >= 2.32-lp150.10.1
  • binutils-gold >= 2.32-lp150.10.1
  • binutils-gold-debuginfo >= 2.32-lp150.10.1
Patchnames:
openSUSE-2019-2415
openSUSE Leap 15.1
  • binutils >= 2.32-lp151.3.3.1
  • binutils-debuginfo >= 2.32-lp151.3.3.1
  • binutils-debugsource >= 2.32-lp151.3.3.1
  • binutils-devel >= 2.32-lp151.3.3.1
  • binutils-devel-32bit >= 2.32-lp151.3.3.1
  • binutils-gold >= 2.32-lp151.3.3.1
  • binutils-gold-debuginfo >= 2.32-lp151.3.3.1
  • cross-aarch64-binutils >= 2.32-lp151.3.3.1
  • cross-aarch64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-aarch64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-arm-binutils >= 2.32-lp151.3.3.1
  • cross-arm-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-arm-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-avr-binutils >= 2.32-lp151.3.3.1
  • cross-avr-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-avr-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-epiphany-binutils >= 2.32-lp151.3.3.1
  • cross-epiphany-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-epiphany-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-hppa-binutils >= 2.32-lp151.3.3.1
  • cross-hppa-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-hppa-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-hppa64-binutils >= 2.32-lp151.3.3.1
  • cross-hppa64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-hppa64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-i386-binutils >= 2.32-lp151.3.3.1
  • cross-i386-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-i386-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-ia64-binutils >= 2.32-lp151.3.3.1
  • cross-ia64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-ia64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-m68k-binutils >= 2.32-lp151.3.3.1
  • cross-m68k-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-m68k-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-mips-binutils >= 2.32-lp151.3.3.1
  • cross-mips-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-mips-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-ppc-binutils >= 2.32-lp151.3.3.1
  • cross-ppc-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-ppc-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-ppc64-binutils >= 2.32-lp151.3.3.1
  • cross-ppc64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-ppc64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-ppc64le-binutils >= 2.32-lp151.3.3.1
  • cross-ppc64le-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-ppc64le-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-riscv64-binutils >= 2.32-lp151.3.3.1
  • cross-riscv64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-riscv64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-rx-binutils >= 2.32-lp151.3.3.1
  • cross-rx-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-rx-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-s390-binutils >= 2.32-lp151.3.3.1
  • cross-s390-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-s390-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-s390x-binutils >= 2.32-lp151.3.3.1
  • cross-s390x-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-s390x-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-sparc-binutils >= 2.32-lp151.3.3.1
  • cross-sparc-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-sparc-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-sparc64-binutils >= 2.32-lp151.3.3.1
  • cross-sparc64-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-sparc64-binutils-debugsource >= 2.32-lp151.3.3.1
  • cross-spu-binutils >= 2.32-lp151.3.3.1
  • cross-spu-binutils-debuginfo >= 2.32-lp151.3.3.1
  • cross-spu-binutils-debugsource >= 2.32-lp151.3.3.1
Patchnames:
openSUSE-2019-2432


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration binutils Affected
SLES for SAP Applications binutils Affected
SUSE Linux Enterprise 15 Module for Basesystem binutils Released
SUSE Linux Enterprise 15 Module for Development Tools binutils Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem binutils Released
SUSE Linux Enterprise 15-SP1 Module for Development Tools binutils Released
SUSE Linux Enterprise 15-SP2 Module for Basesystem binutils Released
SUSE Linux Enterprise 15-SP2 Module for Development Tools binutils Released
SUSE Linux Enterprise Desktop 12 SP3 binutils Affected
SUSE Linux Enterprise Desktop 12 SP4 binutils Released
SUSE Linux Enterprise High Performance Computing 12 SP4 binutils Released
SUSE Linux Enterprise Server 11 SP1 binutils Affected
SUSE Linux Enterprise Server 11 SP3 binutils Affected
SUSE Linux Enterprise Server 11 SP3 LTSS binutils Affected
SUSE Linux Enterprise Server 11 SP4 binutils Affected
SUSE Linux Enterprise Server 12 LTSS binutils Affected
SUSE Linux Enterprise Server 12 SP1 LTSS binutils Released
SUSE Linux Enterprise Server 12 SP2 LTSS binutils Released
SUSE Linux Enterprise Server 12 SP3 binutils Affected
SUSE Linux Enterprise Server 12 SP3 LTSS binutils Released
SUSE Linux Enterprise Server 12 SP4 binutils Released
SUSE Linux Enterprise Server for SAP Applications 12 binutils Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 binutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 binutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 binutils Released
SUSE Linux Enterprise Software Development Kit 11 SP4 binutils Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 binutils Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 binutils Released