Upstream information

CVE-2017-5849 at MITRE

Description

tiffttopnm in netpbm 10.47.63 does not properly use the libtiff TIFFRGBAImageGet function, which allows remote attackers to cause a denial of service (out-of-bounds read and write) via a crafted tiff image file, related to transposing width and height values.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4.4
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4.4
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None Low
Availability Impact High Low
CVSSv3 Version 3 3.1
SUSE Bugzilla entries: 1022790 [RESOLVED / FIXED], 1022791 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libnetpbm-devel >= 10.80.1-150000.3.14.1
  • libnetpbm11 >= 10.80.1-150000.3.14.1
  • netpbm >= 10.80.1-150000.3.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-435
SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-435
SUSE Linux Enterprise Desktop 15 SP6
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Server 15 SP6
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • libnetpbm-devel >= 10.80.1-150000.3.14.1
  • libnetpbm11 >= 10.80.1-150000.3.14.1
  • netpbm >= 10.80.1-150000.3.14.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP6 GA netpbm-10.80.1-150000.3.14.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP6 GA netpbm-10.80.1-150000.3.14.1
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • libnetpbm11 >= 10.80.1-150000.3.14.1
  • netpbm >= 10.80.1-150000.3.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-435
SUSE Linux Enterprise Module for Basesystem 15 SP6
  • libnetpbm11 >= 10.80.1-150000.3.14.1
  • netpbm >= 10.80.1-150000.3.14.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP6 GA netpbm-10.80.1-150000.3.14.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • libnetpbm-devel >= 10.80.1-150000.3.14.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-435
SUSE Linux Enterprise Module for Desktop Applications 15 SP6
  • libnetpbm-devel >= 10.80.1-150000.3.14.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP6 GA netpbm-10.80.1-150000.3.14.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libnetpbm-devel >= 10.66.3-8.10.1
  • libnetpbm11 >= 10.66.3-8.10.1
  • libnetpbm11-32bit >= 10.66.3-8.10.1
  • netpbm >= 10.66.3-8.10.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-434
SUSE-SLE-SERVER-12-SP5-2024-434
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libnetpbm-devel >= 10.66.3-8.10.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-434
openSUSE Leap 15.5
  • libnetpbm-devel >= 10.80.1-150000.3.14.1
  • libnetpbm11 >= 10.80.1-150000.3.14.1
  • libnetpbm11-32bit >= 10.80.1-150000.3.14.1
  • netpbm >= 10.80.1-150000.3.14.1
  • netpbm-vulnerable >= 10.80.1-150000.3.14.1
Patchnames:
openSUSE-SLE-15.5-2024-435
openSUSE Tumbleweed
  • libnetpbm-devel >= 11.5.2-2.1
  • libnetpbm11 >= 11.5.2-2.1
  • libnetpbm11-32bit >= 11.5.2-2.1
  • netpbm >= 11.5.2-2.1
Patchnames:
openSUSE-Tumbleweed-2024-13655


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 netpbm Unsupported
SUSE Linux Enterprise Desktop 15 SP5 netpbm Released
SUSE Linux Enterprise Desktop 15 SP6 netpbm Released
SUSE Linux Enterprise High Performance Computing 12 SP5 netpbm Released
SUSE Linux Enterprise High Performance Computing 15 SP5 netpbm Released
SUSE Linux Enterprise High Performance Computing 15 SP6 netpbm Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 netpbm Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 netpbm Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 netpbm Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP6 netpbm Released
SUSE Linux Enterprise Server 12 SP5 netpbm Released
SUSE Linux Enterprise Server 15 SP5 netpbm Released
SUSE Linux Enterprise Server 15 SP6 netpbm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 netpbm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 netpbm Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 netpbm Released
SUSE Linux Enterprise Software Development Kit 12 SP5 netpbm Released
SUSE Manager Proxy 4.3 netpbm Affected
SUSE Manager Retail Branch Server 4.3 netpbm Affected
SUSE Manager Server 4.3 netpbm Affected
openSUSE Leap 15.5 netpbm Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS netpbm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 netpbm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS netpbm Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 netpbm Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 netpbm Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP4 netpbm Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 netpbm Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 netpbm Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 netpbm Affected
SUSE Linux Enterprise Server 15 SP2 netpbm Affected
SUSE Linux Enterprise Server 15 SP2-LTSS netpbm Affected
SUSE Linux Enterprise Server 15 SP3 netpbm Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS netpbm Affected
SUSE Linux Enterprise Server 15 SP4 netpbm Affected
SUSE Linux Enterprise Server 15 SP4-LTSS netpbm Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 netpbm Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 netpbm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 netpbm Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 netpbm Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 netpbm Affected
SUSE CaaS Platform 4.0 netpbm Affected
SUSE CaaS Platform 4.5 netpbm Unsupported
SUSE Enterprise Storage 6 netpbm Affected
SUSE Enterprise Storage 7 netpbm Affected
SUSE Linux Enterprise Desktop 11 SP4 netpbm Not affected
SUSE Linux Enterprise Desktop 12 netpbm Affected
SUSE Linux Enterprise Desktop 12 SP1 netpbm Unsupported
SUSE Linux Enterprise Desktop 12 SP2 netpbm Unsupported
SUSE Linux Enterprise Desktop 12 SP3 netpbm Affected
SUSE Linux Enterprise Desktop 12 SP4 netpbm Affected
SUSE Linux Enterprise Desktop 15 netpbm Affected
SUSE Linux Enterprise Desktop 15 SP1 netpbm Affected
SUSE Linux Enterprise Desktop 15 SP2 netpbm Affected
SUSE Linux Enterprise Desktop 15 SP3 netpbm Unsupported
SUSE Linux Enterprise High Performance Computing 15 netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 netpbm Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS netpbm Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS netpbm Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS netpbm Affected
SUSE Linux Enterprise Module for Basesystem 15 netpbm Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 netpbm Affected
SUSE Linux Enterprise Module for Desktop Applications 15 netpbm Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 netpbm Affected
SUSE Linux Enterprise Real Time 15 SP2 netpbm Unsupported
SUSE Linux Enterprise Real Time 15 SP3 netpbm Affected
SUSE Linux Enterprise Real Time 15 SP4 netpbm Affected
SUSE Linux Enterprise Server 11 SP1 netpbm Not affected
SUSE Linux Enterprise Server 11 SP3 netpbm Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS netpbm Not affected
SUSE Linux Enterprise Server 11 SP4 netpbm Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS netpbm Not affected
SUSE Linux Enterprise Server 12 netpbm Affected
SUSE Linux Enterprise Server 12 SP1 netpbm Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS netpbm Affected
SUSE Linux Enterprise Server 12 SP2 netpbm Affected
SUSE Linux Enterprise Server 12 SP2-BCL netpbm Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS netpbm Affected
SUSE Linux Enterprise Server 12 SP2-LTSS netpbm Affected
SUSE Linux Enterprise Server 12 SP3 netpbm Affected
SUSE Linux Enterprise Server 12 SP3-BCL netpbm Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS netpbm Affected
SUSE Linux Enterprise Server 12 SP3-LTSS netpbm Affected
SUSE Linux Enterprise Server 12 SP4 netpbm Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS netpbm Affected
SUSE Linux Enterprise Server 12 SP4-LTSS netpbm Affected
SUSE Linux Enterprise Server 12-LTSS netpbm Affected
SUSE Linux Enterprise Server 15 netpbm Affected
SUSE Linux Enterprise Server 15 SP1 netpbm Affected
SUSE Linux Enterprise Server 15 SP1-BCL netpbm Affected
SUSE Linux Enterprise Server 15 SP1-LTSS netpbm Affected
SUSE Linux Enterprise Server 15 SP2-BCL netpbm Affected
SUSE Linux Enterprise Server 15 SP3-BCL netpbm Affected
SUSE Linux Enterprise Server 15-LTSS netpbm Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 netpbm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 netpbm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 netpbm Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 15 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 netpbm Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 netpbm Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 netpbm Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 netpbm Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 netpbm Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 netpbm Affected
SUSE Manager Proxy 4.0 netpbm Affected
SUSE Manager Proxy 4.1 netpbm Unsupported
SUSE Manager Proxy 4.2 netpbm Unsupported
SUSE Manager Retail Branch Server 4.0 netpbm Affected
SUSE Manager Retail Branch Server 4.1 netpbm Unsupported
SUSE Manager Retail Branch Server 4.2 netpbm Unsupported
SUSE Manager Server 4.0 netpbm Affected
SUSE Manager Server 4.1 netpbm Unsupported
SUSE Manager Server 4.2 netpbm Unsupported
SUSE OpenStack Cloud 7 netpbm Affected
SUSE OpenStack Cloud 8 netpbm Affected
SUSE OpenStack Cloud 9 netpbm Affected
SUSE OpenStack Cloud Crowbar 8 netpbm Affected
SUSE OpenStack Cloud Crowbar 9 netpbm Affected


SUSE Timeline for this CVE

CVE page created: Tue Jan 31 13:30:51 2017
CVE page last modified: Sat Jun 15 23:24:44 2024