Upstream information

CVE-2015-8982 at MITRE

Description

Integer overflow in the strxfrm function in the GNU C Library (aka glibc or libc6) before 2.21 allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string, which triggers a stack-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entries: 920169 [RESOLVED], 920338 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 glibc Already fixed
SLES for SAP Applications glibc Released
SUSE Linux Enterprise Desktop 11 SP1 glibc Released
SUSE Linux Enterprise Desktop 11 SP2 glibc Released
SUSE Linux Enterprise Desktop 11 SP3 glibc Released
SUSE Linux Enterprise Desktop 11 SP4 glibc Released
SUSE Linux Enterprise Desktop 12 glibc Released
SUSE Linux Enterprise Point of Service 11 SP3 glibc In progress
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP2 glibc Released
SUSE Linux Enterprise Server 11 SP2 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP2 for VMware glibc Released
SUSE Linux Enterprise Server 11 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 for VMware glibc Released
SUSE Linux Enterprise Server 11 SP4 glibc Released
SUSE Linux Enterprise Server 11 SP4 LTSS glibc In progress
SUSE Linux Enterprise Server 12 glibc Released
SUSE Linux Enterprise Server 12 SP2 BCL glibc Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON glibc Already fixed
SUSE Linux Enterprise Server 12 SP2 LTSS SAP glibc Already fixed
SUSE Linux Enterprise Server 12 SP3 BCL glibc Already fixed
SUSE Linux Enterprise Server 12 SP3 ESPOS glibc Already fixed
SUSE Linux Enterprise Server 12 SP3 LTSS glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glibc Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 glibc Released
SUSE Linux Enterprise Software Development Kit 11 SP3 glibc Released
SUSE Linux Enterprise Software Development Kit 11 SP4 glibc Released
SUSE Linux Enterprise Software Development Kit 12 glibc Released
SUSE OpenStack Cloud 8 glibc Already fixed
SUSE OpenStack Cloud Crowbar 8 glibc Already fixed