Upstream information

CVE-2023-50255 at MITRE

Description

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1218428 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP4
  • deepin-compressor >= 5.12.2-bp154.2.3.1
  • deepin-compressor-lang >= 5.12.2-bp154.2.3.1
Patchnames:
openSUSE-2023-424
SUSE Package Hub 15 SP5
  • deepin-compressor >= 5.12.13-bp155.2.3.1
  • deepin-compressor-lang >= 5.12.13-bp155.2.3.1
Patchnames:
openSUSE-2023-423
openSUSE Leap 15.4
  • deepin-compressor >= 5.12.2-bp154.2.3.1
  • deepin-compressor-lang >= 5.12.2-bp154.2.3.1
Patchnames:
openSUSE-2023-424
openSUSE Leap 15.5
  • deepin-compressor >= 5.12.13-bp155.2.3.1
  • deepin-compressor-lang >= 5.12.13-bp155.2.3.1
Patchnames:
openSUSE-2023-423
openSUSE Tumbleweed
  • deepin-compressor >= 5.12.13-2.1
  • deepin-compressor-lang >= 5.12.13-2.1
Patchnames:
openSUSE-Tumbleweed-2024-13541


SUSE Timeline for this CVE

CVE page created: Wed Dec 27 19:00:31 2023
CVE page last modified: Sun Jun 16 02:59:26 2024