Upstream information

CVE-2023-40184 at MITRE

Description

xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_start_session` function can return non-zero (1) value on, e.g., PAM error which may result in in session restrictions such as max concurrent sessions per user by PAM (ex ./etc/security/limits.conf) to be bypassed. Users (administrators) don't use restrictions by PAM are not affected. This issue has been addressed in release version 0.9.23. Users are advised to upgrade. There are no known workarounds for this issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 2.6 4.8
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:L CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity High High
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Low High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1214805 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • xrdp >= 0.9.10-3.16.1
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAPCAL-Azure
Image SLES15-SP4-SAP
Image SLES15-SP4-SAP-Azure
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP4-SAP-EC2
Image SLES15-SP4-SAP-GCE
Image SLES15-SP4-SAPCAL
Image SLES15-SP4-SAPCAL-Azure
Image SLES15-SP4-SAPCAL-EC2
Image SLES15-SP4-SAPCAL-GCE
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAPCAL-Azure
Image SLES15-SP5-SAPCAL-EC2
Image SLES15-SP5-SAPCAL-GCE
  • xrdp >= 0.9.13.1-150200.4.24.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3830
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3830
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • xrdp >= 0.9.10-3.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2023-3735
SUSE-SLE-SERVER-12-SP5-2023-4873
SUSE Manager Proxy 4.2
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-3830
SUSE Manager Retail Branch Server 4.2
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2023-3830
SUSE Manager Server 4.2
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-3830
openSUSE Leap 15.4
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
openSUSE-SLE-15.4-2023-3830
openSUSE Leap 15.5
  • libpainter0 >= 0.9.13.1-150200.4.24.1
  • librfxencode0 >= 0.9.13.1-150200.4.24.1
  • xrdp >= 0.9.13.1-150200.4.24.1
  • xrdp-devel >= 0.9.13.1-150200.4.24.1
Patchnames:
openSUSE-SLE-15.5-2023-3830
openSUSE Tumbleweed
  • libpainter0 >= 0.9.23.1-1.1
  • librfxencode0 >= 0.9.23.1-1.1
  • xrdp >= 0.9.23.1-1.1
  • xrdp-devel >= 0.9.23.1-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13399


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 xrdp Affected
SUSE Linux Enterprise Desktop 15 SP5 xrdp Released
SUSE Linux Enterprise Desktop 15 SP6 xrdp Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 xrdp Released
SUSE Linux Enterprise High Performance Computing 15 SP5 xrdp Released
SUSE Linux Enterprise High Performance Computing 15 SP6 xrdp Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 xrdp Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 xrdp Already fixed
SUSE Linux Enterprise Server 12 SP5 xrdp Released
SUSE Linux Enterprise Server 15 SP5 xrdp Released
SUSE Linux Enterprise Server 15 SP6 xrdp Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xrdp Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 xrdp Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 xrdp Already fixed
SUSE Manager Proxy 4.3 xrdp Released
SUSE Manager Retail Branch Server 4.3 xrdp Released
SUSE Manager Server 4.3 xrdp Released
openSUSE Leap 15.5 xrdp Released
openSUSE Leap 15.6 xrdp Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 xrdp Released
SUSE Linux Enterprise High Performance Computing 15 SP2 xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 xrdp Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS xrdp Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 xrdp Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 xrdp Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 xrdp Released
SUSE Linux Enterprise Server 15 SP2 xrdp Affected
SUSE Linux Enterprise Server 15 SP2-LTSS xrdp Affected
SUSE Linux Enterprise Server 15 SP3 xrdp Affected
SUSE Linux Enterprise Server 15 SP3-LTSS xrdp Affected
SUSE Linux Enterprise Server 15 SP4 xrdp Released
SUSE Linux Enterprise Server 15 SP4-LTSS xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xrdp Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 xrdp Affected
SUSE CaaS Platform 4.0 xrdp Unsupported
SUSE Enterprise Storage 6 xrdp Unsupported
SUSE Enterprise Storage 7 xrdp Affected
SUSE Linux Enterprise Desktop 12 SP2 xrdp Affected
SUSE Linux Enterprise Desktop 12 SP3 xrdp Affected
SUSE Linux Enterprise Desktop 12 SP4 xrdp Affected
SUSE Linux Enterprise Desktop 15 xrdp Unsupported
SUSE Linux Enterprise Desktop 15 SP1 xrdp Unsupported
SUSE Linux Enterprise Desktop 15 SP2 xrdp Affected
SUSE Linux Enterprise Desktop 15 SP3 xrdp Affected
SUSE Linux Enterprise High Performance Computing 15 xrdp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 xrdp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS xrdp Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS xrdp Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS xrdp Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS xrdp Unsupported
SUSE Linux Enterprise Module for Basesystem 15 xrdp Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 xrdp Unsupported
SUSE Linux Enterprise Real Time 15 SP2 xrdp Affected
SUSE Linux Enterprise Real Time 15 SP3 xrdp Affected
SUSE Linux Enterprise Real Time 15 SP4 xrdp Affected
SUSE Linux Enterprise Server 11 SP4 xrdp Affected
SUSE Linux Enterprise Server 11 SP4 LTSS xrdp Affected
SUSE Linux Enterprise Server 11 SP4-LTSS xrdp Affected
SUSE Linux Enterprise Server 12 SP2 xrdp Affected
SUSE Linux Enterprise Server 12 SP2-BCL xrdp Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS xrdp Affected
SUSE Linux Enterprise Server 12 SP2-LTSS xrdp Affected
SUSE Linux Enterprise Server 12 SP3 xrdp Affected
SUSE Linux Enterprise Server 12 SP3-BCL xrdp Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS xrdp Affected
SUSE Linux Enterprise Server 12 SP3-LTSS xrdp Affected
SUSE Linux Enterprise Server 12 SP4 xrdp Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS xrdp Affected
SUSE Linux Enterprise Server 12 SP4-LTSS xrdp Affected
SUSE Linux Enterprise Server 15 xrdp Unsupported
SUSE Linux Enterprise Server 15 SP1 xrdp Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL xrdp Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS xrdp Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL xrdp Affected
SUSE Linux Enterprise Server 15 SP3-BCL xrdp Affected
SUSE Linux Enterprise Server 15-LTSS xrdp Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xrdp Affected
SUSE Linux Enterprise Server for SAP Applications 15 xrdp Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 xrdp Unsupported
SUSE Manager Proxy 4.0 xrdp Unsupported
SUSE Manager Proxy 4.1 xrdp Affected
SUSE Manager Proxy 4.2 xrdp Released
SUSE Manager Retail Branch Server 4.0 xrdp Unsupported
SUSE Manager Retail Branch Server 4.1 xrdp Affected
SUSE Manager Retail Branch Server 4.2 xrdp Released
SUSE Manager Server 4.0 xrdp Unsupported
SUSE Manager Server 4.1 xrdp Affected
SUSE Manager Server 4.2 xrdp Released
SUSE OpenStack Cloud 7 xrdp Affected
SUSE OpenStack Cloud 8 xrdp Affected
SUSE OpenStack Cloud 9 xrdp Affected
SUSE OpenStack Cloud Crowbar 8 xrdp Affected
SUSE OpenStack Cloud Crowbar 9 xrdp Affected
openSUSE Leap 15.4 xrdp Released


SUSE Timeline for this CVE

CVE page created: Wed Aug 30 22:01:26 2023
CVE page last modified: Tue Jun 18 10:10:32 2024