Upstream information

CVE-2023-38407 at MITRE

Description

bgpd/bgp_label.c in FRRouting (FRR) before 8.5 attempts to read beyond the end of the stream during labeled unicast parsing.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1216899 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • frr >= 7.5.1-13.el8_9.3
  • frr-selinux >= 7.5.1-13.el8_9.3
Patchnames:
RHSA-2024:0130
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Server Applications 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • frr >= 8.4-150500.4.15.1
  • frr-devel >= 8.4-150500.4.15.1
  • libfrr0 >= 8.4-150500.4.15.1
  • libfrr_pb0 >= 8.4-150500.4.15.1
  • libfrrcares0 >= 8.4-150500.4.15.1
  • libfrrfpm_pb0 >= 8.4-150500.4.15.1
  • libfrrospfapiclient0 >= 8.4-150500.4.15.1
  • libfrrsnmp0 >= 8.4-150500.4.15.1
  • libfrrzmq0 >= 8.4-150500.4.15.1
  • libmlag_pb0 >= 8.4-150500.4.15.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP5-2023-4663
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Module for Server Applications 15 SP6
SUSE Linux Enterprise Server 15 SP6
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • frr >= 8.4-150500.4.15.1
  • frr-devel >= 8.4-150500.4.15.1
  • libfrr0 >= 8.4-150500.4.15.1
  • libfrr_pb0 >= 8.4-150500.4.15.1
  • libfrrcares0 >= 8.4-150500.4.15.1
  • libfrrfpm_pb0 >= 8.4-150500.4.15.1
  • libfrrospfapiclient0 >= 8.4-150500.4.15.1
  • libfrrsnmp0 >= 8.4-150500.4.15.1
  • libfrrzmq0 >= 8.4-150500.4.15.1
  • libmlag_pb0 >= 8.4-150500.4.15.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP6 GA frr-8.4-150500.4.15.1
openSUSE Leap 15.5
  • frr >= 8.4-150500.4.15.1
  • frr-devel >= 8.4-150500.4.15.1
  • libfrr0 >= 8.4-150500.4.15.1
  • libfrr_pb0 >= 8.4-150500.4.15.1
  • libfrrcares0 >= 8.4-150500.4.15.1
  • libfrrfpm_pb0 >= 8.4-150500.4.15.1
  • libfrrospfapiclient0 >= 8.4-150500.4.15.1
  • libfrrsnmp0 >= 8.4-150500.4.15.1
  • libfrrzmq0 >= 8.4-150500.4.15.1
  • libmlag_pb0 >= 8.4-150500.4.15.1
Patchnames:
openSUSE-SLE-15.5-2023-4663
openSUSE Tumbleweed
  • frr >= 8.4-8.1
  • frr-devel >= 8.4-8.1
  • libfrr0 >= 8.4-8.1
  • libfrr_pb0 >= 8.4-8.1
  • libfrrcares0 >= 8.4-8.1
  • libfrrfpm_pb0 >= 8.4-8.1
  • libfrrospfapiclient0 >= 8.4-8.1
  • libfrrsnmp0 >= 8.4-8.1
  • libfrrzmq0 >= 8.4-8.1
  • libmlag_pb0 >= 8.4-8.1
Patchnames:
openSUSE-Tumbleweed-2024-13487


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 frr Unsupported
SUSE Enterprise Storage 7.1 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP5 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP5 frr Released
SUSE Linux Enterprise High Performance Computing 15 SP5 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP6 frr Released
SUSE Linux Enterprise High Performance Computing 15 SP6 quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP5 frr Released
SUSE Linux Enterprise Module for Server Applications 15 SP5 quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP6 frr Released
SUSE Linux Enterprise Module for Server Applications 15 SP6 quagga Unsupported
SUSE Linux Enterprise Server 12 SP5 quagga Unsupported
SUSE Linux Enterprise Server 15 SP5 frr Released
SUSE Linux Enterprise Server 15 SP5 quagga Unsupported
SUSE Linux Enterprise Server 15 SP6 frr Released
SUSE Linux Enterprise Server 15 SP6 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP5 frr Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP6 frr Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 quagga Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP5 quagga Unsupported
SUSE Manager Proxy 4.3 frr Unsupported
SUSE Manager Proxy 4.3 quagga Unsupported
SUSE Manager Retail Branch Server 4.3 frr Unsupported
SUSE Manager Retail Branch Server 4.3 quagga Unsupported
SUSE Manager Server 4.3 frr Unsupported
SUSE Manager Server 4.3 quagga Unsupported
openSUSE Leap 15.5 frr Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS frr Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP3 frr Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP3 quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 frr Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 quagga Unsupported
SUSE Linux Enterprise Server 15 SP2 quagga Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS quagga Unsupported
SUSE Linux Enterprise Server 15 SP3 frr Unsupported
SUSE Linux Enterprise Server 15 SP3 quagga Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS frr Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS quagga Unsupported
SUSE Linux Enterprise Server 15 SP4 frr Unsupported
SUSE Linux Enterprise Server 15 SP4 quagga Unsupported
SUSE Linux Enterprise Server 15 SP4-LTSS frr Unsupported
SUSE Linux Enterprise Server 15 SP4-LTSS quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 frr Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 frr Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 quagga Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 quagga Unsupported
SUSE CaaS Platform 4.0 quagga Unsupported
SUSE Enterprise Storage 6 quagga Unsupported
SUSE Enterprise Storage 7 quagga Unsupported
SUSE Linux Enterprise Desktop 11 SP4 quagga Affected
SUSE Linux Enterprise Desktop 12 SP2 quagga Unsupported
SUSE Linux Enterprise Desktop 12 SP3 quagga Unsupported
SUSE Linux Enterprise Desktop 12 SP4 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS quagga Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 quagga Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP1 quagga Unsupported
SUSE Linux Enterprise Real Time 15 SP2 quagga Unsupported
SUSE Linux Enterprise Real Time 15 SP3 frr Unsupported
SUSE Linux Enterprise Real Time 15 SP3 quagga Unsupported
SUSE Linux Enterprise Real Time 15 SP4 frr Unsupported
SUSE Linux Enterprise Real Time 15 SP4 quagga Unsupported
SUSE Linux Enterprise Server 11 SP3 quagga Affected
SUSE Linux Enterprise Server 11 SP3-LTSS quagga Affected
SUSE Linux Enterprise Server 11 SP4 quagga Affected
SUSE Linux Enterprise Server 11 SP4 LTSS quagga Affected
SUSE Linux Enterprise Server 11 SP4-LTSS quagga Affected
SUSE Linux Enterprise Server 12 SP2 quagga Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL quagga Unsupported
SUSE Linux Enterprise Server 12 SP2-ESPOS quagga Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS quagga Unsupported
SUSE Linux Enterprise Server 12 SP3 quagga Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL quagga Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS quagga Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS quagga Unsupported
SUSE Linux Enterprise Server 12 SP4 quagga Unsupported
SUSE Linux Enterprise Server 12 SP4-ESPOS quagga Unsupported
SUSE Linux Enterprise Server 12 SP4-LTSS quagga Unsupported
SUSE Linux Enterprise Server 15 quagga Unsupported
SUSE Linux Enterprise Server 15 SP1 quagga Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL quagga Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS quagga Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL quagga Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL frr Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL quagga Unsupported
SUSE Linux Enterprise Server 15-LTSS quagga Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 quagga Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 quagga Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 quagga Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 quagga Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 quagga Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 quagga Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 quagga Unsupported
SUSE Manager Proxy 4.0 quagga Unsupported
SUSE Manager Proxy 4.1 quagga Unsupported
SUSE Manager Proxy 4.2 frr Unsupported
SUSE Manager Proxy 4.2 quagga Unsupported
SUSE Manager Retail Branch Server 4.0 quagga Unsupported
SUSE Manager Retail Branch Server 4.1 quagga Unsupported
SUSE Manager Retail Branch Server 4.2 frr Unsupported
SUSE Manager Retail Branch Server 4.2 quagga Unsupported
SUSE Manager Server 4.0 quagga Unsupported
SUSE Manager Server 4.1 quagga Unsupported
SUSE Manager Server 4.2 frr Unsupported
SUSE Manager Server 4.2 quagga Unsupported
SUSE OpenStack Cloud 7 quagga Unsupported
SUSE OpenStack Cloud 8 quagga Unsupported
SUSE OpenStack Cloud 9 quagga Unsupported
SUSE OpenStack Cloud Crowbar 8 quagga Unsupported
SUSE OpenStack Cloud Crowbar 9 quagga Unsupported


SUSE Timeline for this CVE

CVE page created: Mon Nov 6 09:00:18 2023
CVE page last modified: Sun Jun 16 02:54:10 2024