Upstream information

CVE-2023-38285 at MITRE

Description

Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1213702 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP4
  • libmodsecurity3 >= 3.0.10-bp154.2.3.1
  • libmodsecurity3-32bit >= 3.0.10-bp154.2.3.1
  • libmodsecurity3-64bit >= 3.0.10-bp154.2.3.1
  • modsecurity >= 3.0.10-bp154.2.3.1
  • modsecurity-devel >= 3.0.10-bp154.2.3.1
Patchnames:
openSUSE-2023-269
SUSE Package Hub 15 SP5
  • libmodsecurity3 >= 3.0.10-bp155.3.3.1
  • libmodsecurity3-32bit >= 3.0.10-bp155.3.3.1
  • libmodsecurity3-64bit >= 3.0.10-bp155.3.3.1
  • modsecurity >= 3.0.10-bp155.3.3.1
  • modsecurity-devel >= 3.0.10-bp155.3.3.1
Patchnames:
openSUSE-2023-257
openSUSE Leap 15.4
  • libmodsecurity3 >= 3.0.10-bp154.2.3.1
  • libmodsecurity3-32bit >= 3.0.10-bp154.2.3.1
  • libmodsecurity3-64bit >= 3.0.10-bp154.2.3.1
  • modsecurity >= 3.0.10-bp154.2.3.1
  • modsecurity-devel >= 3.0.10-bp154.2.3.1
Patchnames:
openSUSE-2023-269
openSUSE Leap 15.5
  • libmodsecurity3 >= 3.0.10-bp155.3.3.1
  • libmodsecurity3-32bit >= 3.0.10-bp155.3.3.1
  • libmodsecurity3-64bit >= 3.0.10-bp155.3.3.1
  • modsecurity >= 3.0.10-bp155.3.3.1
  • modsecurity-devel >= 3.0.10-bp155.3.3.1
Patchnames:
openSUSE-2023-257
openSUSE Tumbleweed
  • libmodsecurity3 >= 3.0.10-1.1
  • modsecurity >= 3.0.10-1.1
  • modsecurity-devel >= 3.0.10-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13195


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP6 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP6 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP6 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.3 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.3 apache2-mod_security2 Not affected
SUSE Manager Server 4.3 apache2-mod_security2 Not affected
SUSE Package Hub 15 SP5 modsecurity Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 apache2-mod_security2 Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 apache2-mod_security2 Not affected
SUSE CaaS Platform 4.0 apache2-mod_security2 Not affected
SUSE Enterprise Storage 6 apache2-mod_security2 Not affected
SUSE Enterprise Storage 7 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Real Time 15 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Real Time 15 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Real Time 15 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL apache2-mod_security2 Not affected
SUSE Linux Enterprise Server 15-LTSS apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 apache2-mod_security2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.0 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.1 apache2-mod_security2 Not affected
SUSE Manager Proxy 4.2 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.0 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.1 apache2-mod_security2 Not affected
SUSE Manager Retail Branch Server 4.2 apache2-mod_security2 Not affected
SUSE Manager Server 4.0 apache2-mod_security2 Not affected
SUSE Manager Server 4.1 apache2-mod_security2 Not affected
SUSE Manager Server 4.2 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 7 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 8 apache2-mod_security2 Not affected
SUSE OpenStack Cloud 9 apache2-mod_security2 Not affected
SUSE OpenStack Cloud Crowbar 8 apache2-mod_security2 Not affected
SUSE OpenStack Cloud Crowbar 9 apache2-mod_security2 Not affected
SUSE Package Hub 15 SP4 modsecurity Released


SUSE Timeline for this CVE

CVE page created: Thu Jul 27 00:03:41 2023
CVE page last modified: Sun Jun 16 02:54:05 2024