Upstream information

CVE-2020-8315 at MITRE

Description

In Python (CPython) 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1, an insecure dependency load upon launch on Windows 7 may result in an attacker's copy of api-ms-win-core-path-l1-1-0.dll being loaded and used instead of the system's copy. Windows 8 and later are unaffected.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1173935 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration python Not affected
SLED-10-SP3 python Not affected
SLED-10-SP4 python Not affected
SLES for SAP Applications python Not affected
SLES-10-SP3 python Not affected
SLES-10-SP4 python Not affected
SLES_LTSS-10-SP4 python Not affected
SUSE CaaS Platform 3.0 python Not affected
SUSE Container as a Service Platform 1.0 python Affected
SUSE Container as a Service Platform 2.0 python Not affected
SUSE Enterprise Storage 5 python Not affected
SUSE Linux Enterprise 12 Module for Web and Scripting python3 Not affected
SUSE Linux Enterprise 15 Module for Basesystem python Not affected
SUSE Linux Enterprise 15 Module for Basesystem python3 Not affected
SUSE Linux Enterprise 15 Module for Desktop Applications python Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem python Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem python3 Not affected
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications python Not affected
SUSE Linux Enterprise 15-SP1 Module for Python 2 python Not affected
SUSE Linux Enterprise 15-SP2 Module for Basesystem python Not affected
SUSE Linux Enterprise 15-SP2 Module for Basesystem python3 Not affected
SUSE Linux Enterprise 15-SP2 Module for Desktop Applications python Not affected
SUSE Linux Enterprise 15-SP2 Module for Python 2 python Not affected
SUSE Linux Enterprise Desktop 11 python Not affected
SUSE Linux Enterprise Desktop 11 SP1 python Not affected
SUSE Linux Enterprise Desktop 11 SP2 python Not affected
SUSE Linux Enterprise Desktop 11 SP3 python Not affected
SUSE Linux Enterprise Desktop 11 SP4 python Not affected
SUSE Linux Enterprise Desktop 12 python Not affected
SUSE Linux Enterprise Desktop 12 python3 Not affected
SUSE Linux Enterprise Desktop 12 SP1 python Not affected
SUSE Linux Enterprise Desktop 12 SP1 python3 Not affected
SUSE Linux Enterprise Desktop 12 SP2 python Not affected
SUSE Linux Enterprise Desktop 12 SP2 python3 Not affected
SUSE Linux Enterprise Desktop 12 SP3 python Not affected
SUSE Linux Enterprise Desktop 12 SP3 python3 Not affected
SUSE Linux Enterprise Desktop 12 SP4 python Not affected
SUSE Linux Enterprise Desktop 12 SP4 python3 Not affected
SUSE Linux Enterprise Desktop 12 SP5 python Not affected
SUSE Linux Enterprise Desktop 12 SP5 python3 Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP3 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python36 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS python3 Not affected
SUSE Linux Enterprise Server 11 python Not affected
SUSE Linux Enterprise Server 11 SP1 python Not affected
SUSE Linux Enterprise Server 11 SP1 python27 Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS python Not affected
SUSE Linux Enterprise Server 11 SP2 python Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS python Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware python Not affected
SUSE Linux Enterprise Server 11 SP3 python Not affected
SUSE Linux Enterprise Server 11 SP3 python27 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS python Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware python Not affected
SUSE Linux Enterprise Server 11 SP4 python Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS python Not affected
SUSE Linux Enterprise Server 12 python Not affected
SUSE Linux Enterprise Server 12 python3 Not affected
SUSE Linux Enterprise Server 12 LTSS python Not affected
SUSE Linux Enterprise Server 12 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP1 python Not affected
SUSE Linux Enterprise Server 12 SP1 python3 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP2 python Not affected
SUSE Linux Enterprise Server 12 SP2 python3 Not affected
SUSE Linux Enterprise Server 12 SP2 BCL python Not affected
SUSE Linux Enterprise Server 12 SP2 BCL python3 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP3 python Not affected
SUSE Linux Enterprise Server 12 SP3 python3 Not affected
SUSE Linux Enterprise Server 12 SP3 BCL python Not affected
SUSE Linux Enterprise Server 12 SP3 BCL python3 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS python Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS python3 Not affected
SUSE Linux Enterprise Server 12 SP4 python Not affected
SUSE Linux Enterprise Server 12 SP4 python3 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS python Affected
SUSE Linux Enterprise Server 12 SP4 LTSS python3 Affected
SUSE Linux Enterprise Server 12 SP5 python Not affected
SUSE Linux Enterprise Server 12 SP5 python3 Not affected
SUSE Linux Enterprise Server 12 SP5 python36 Not affected
SUSE Linux Enterprise Server 15 LTSS python Not affected
SUSE Linux Enterprise Server 15 LTSS python3 Not affected
SUSE Linux Enterprise Server ESPOS 15 python Not affected
SUSE Linux Enterprise Server ESPOS 15 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python36 Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One python Not affected
SUSE Linux Enterprise Server for the Raspberry Pi python Not affected
SUSE Linux Enterprise Server for the Raspberry Pi python3 Not affected
SUSE Linux Enterprise Software Development Kit 11 python Not affected
SUSE Linux Enterprise Software Development Kit 11 SP1 python Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 python Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 python Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 python Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 python3 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 python3 Not affected