Upstream information

CVE-2019-13291 at MITRE

Description

In Xpdf 4.01.01, there is a heap-based buffer over-read in the function DCTStream::readScan() located at Stream.cc. It can, for example, be triggered by sending a crafted PDF document to the pdftops tool. It might allow an attacker to cause Information Disclosure.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.9
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1140746 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications poppler Not affected
SUSE Linux Enterprise 15 Module for Basesystem poppler Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem poppler Not affected
SUSE Linux Enterprise Desktop 12 SP3 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP4 poppler Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP1 poppler Not affected
SUSE Linux Enterprise Server 11 SP1 xpdf Not affected
SUSE Linux Enterprise Server 11 SP3 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP3 poppler Not affected
SUSE Linux Enterprise Server 12 SP4 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Not affected
SUSE Linux Enterprise Software Bootstrap Kit 12 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler Not affected