Upstream information

CVE-2019-13287 at MITRE

Description

In Xpdf 4.01.01, there is an out-of-bounds read vulnerability in the function SplashXPath::strokeAdjust() located at splash/SplashXPath.cc. It can, for example, be triggered by sending a crafted PDF document to the pdftoppm tool. It might allow an attacker to cause Information Disclosure. This is related to CVE-2018-16368.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 3.9
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1140745 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libpoppler-cpp0 >= 0.43.0-16.40.1
  • libpoppler-devel >= 0.43.0-16.40.1
  • libpoppler-glib-devel >= 0.43.0-16.40.1
  • libpoppler-glib8 >= 0.43.0-16.40.1
  • libpoppler-qt4-4 >= 0.43.0-16.40.1
  • libpoppler-qt4-devel >= 0.43.0-16.40.1
  • libpoppler60 >= 0.43.0-16.40.1
  • poppler-tools >= 0.43.0-16.40.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.40.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-4362
SUSE-SLE-SERVER-12-SP5-2023-4362
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpoppler-cpp0 >= 0.43.0-16.40.1
  • libpoppler-devel >= 0.43.0-16.40.1
  • libpoppler-glib-devel >= 0.43.0-16.40.1
  • libpoppler-qt4-devel >= 0.43.0-16.40.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.40.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-4362
openSUSE Leap 15.4
  • libpoppler73 >= 0.62.0-150000.4.28.2
  • libpoppler73-32bit >= 0.62.0-150000.4.28.2
Patchnames:
openSUSE-SLE-15.4-2023-4187


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 poppler Released
SUSE Linux Enterprise High Performance Computing 12 SP5 poppler-qt Released
SUSE Linux Enterprise Server 12 SP5 poppler Released
SUSE Linux Enterprise Server 12 SP5 poppler-qt Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 poppler Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 poppler-qt Released
SUSE Linux Enterprise Software Bootstrap Kit 12 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 poppler Released
SUSE Linux Enterprise Software Development Kit 12 SP5 poppler-qt Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 15 SP2 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 poppler Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 poppler Affected
HPE Helion OpenStack 8 poppler-qt Affected
SLES for SAP Applications 11 SP3 poppler Not affected
SUSE CaaS Platform 4.0 poppler Affected
SUSE Enterprise Storage 6 poppler Unsupported
SUSE Linux Enterprise Desktop 11 SP4 poppler Not affected
SUSE Linux Enterprise Desktop 12 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP1 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP2 poppler Affected
SUSE Linux Enterprise Desktop 12 SP2 poppler-qt Affected
SUSE Linux Enterprise Desktop 12 SP3 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP3 poppler-qt Affected
SUSE Linux Enterprise Desktop 12 SP4 poppler Not affected
SUSE Linux Enterprise Desktop 12 SP4 poppler-qt Affected
SUSE Linux Enterprise Desktop 15 poppler Not affected
SUSE Linux Enterprise Desktop 15 SP1 poppler Unsupported
SUSE Linux Enterprise Desktop 15 SP2 poppler Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 poppler Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 poppler Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS poppler Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS poppler Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS poppler Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS poppler Affected
SUSE Linux Enterprise Module for Basesystem 15 poppler Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 poppler Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP1 poppler-qt5 Affected
SUSE Linux Enterprise Server 11 SP3 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS poppler Not affected
SUSE Linux Enterprise Server 12 poppler Not affected
SUSE Linux Enterprise Server 12 SP1 poppler Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP2 poppler Affected
SUSE Linux Enterprise Server 12 SP2 poppler-qt Affected
SUSE Linux Enterprise Server 12 SP2-BCL poppler Affected
SUSE Linux Enterprise Server 12 SP2-BCL poppler-qt Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS poppler-qt Affected
SUSE Linux Enterprise Server 12 SP2-LTSS poppler Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS poppler-qt Affected
SUSE Linux Enterprise Server 12 SP3 poppler Not affected
SUSE Linux Enterprise Server 12 SP3 poppler-qt Affected
SUSE Linux Enterprise Server 12 SP3-BCL poppler Affected
SUSE Linux Enterprise Server 12 SP3-BCL poppler-qt Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS poppler-qt Affected
SUSE Linux Enterprise Server 12 SP3-LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP3-LTSS poppler-qt Affected
SUSE Linux Enterprise Server 12 SP4 poppler Not affected
SUSE Linux Enterprise Server 12 SP4 poppler-qt Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS poppler Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS poppler-qt Affected
SUSE Linux Enterprise Server 12 SP4-LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP4-LTSS poppler-qt Affected
SUSE Linux Enterprise Server 12-LTSS poppler Not affected
SUSE Linux Enterprise Server 15 poppler Not affected
SUSE Linux Enterprise Server 15 SP1 poppler Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL poppler Affected
SUSE Linux Enterprise Server 15 SP1-LTSS poppler Affected
SUSE Linux Enterprise Server 15-LTSS poppler Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 poppler Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 poppler-qt Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler-qt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler-qt Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler-qt Affected
SUSE Linux Enterprise Server for SAP Applications 15 poppler Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 poppler Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 poppler-qt Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler-qt Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler-qt Affected
SUSE Linux Enterprise Workstation Extension 15 SP2 poppler Affected
SUSE Manager Proxy 4.0 poppler Unsupported
SUSE Manager Retail Branch Server 4.0 poppler Unsupported
SUSE Manager Server 4.0 poppler Unsupported
SUSE OpenStack Cloud 7 poppler Affected
SUSE OpenStack Cloud 7 poppler-qt Affected
SUSE OpenStack Cloud 8 poppler Affected
SUSE OpenStack Cloud 8 poppler-qt Affected
SUSE OpenStack Cloud 9 poppler Affected
SUSE OpenStack Cloud 9 poppler-qt Affected
SUSE OpenStack Cloud Crowbar 8 poppler Affected
SUSE OpenStack Cloud Crowbar 8 poppler-qt Affected
SUSE OpenStack Cloud Crowbar 9 poppler Affected
SUSE OpenStack Cloud Crowbar 9 poppler-qt Affected
openSUSE Leap 15.4 poppler Released


SUSE Timeline for this CVE

CVE page created: Fri Jul 5 06:14:07 2019
CVE page last modified: Sun May 19 16:27:33 2024