Upstream information

CVE-2017-9115 at MITRE

Description

In OpenEXR 2.2.0, an invalid write of size 2 in the = operator function in half.h could cause the application to crash or execute arbitrary code.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1040115 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP4
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.10.1
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.10.1
  • openexr >= 2.1.0-6.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1962
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.13.1
  • openexr >= 2.1.0-6.13.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libIlmImf-2_2-23 >= 2.2.1-3.6.1
  • libIlmImfUtil-2_2-23 >= 2.2.1-3.6.1
  • openexr >= 2.2.1-3.6.1
  • openexr-devel >= 2.2.1-3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-1963
SUSE Linux Enterprise Module for Desktop Applications 15
  • libIlmImf-2_2-23 >= 2.2.1-3.6.1
  • libIlmImfUtil-2_2-23 >= 2.2.1-3.6.1
  • openexr >= 2.2.1-3.6.1
  • openexr-devel >= 2.2.1-3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-1963
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • libIlmImf-2_2-23-32bit >= 2.2.1-3.6.1
  • libIlmImfUtil-2_2-23-32bit >= 2.2.1-3.6.1
  • openexr >= 2.2.1-3.6.1
  • openexr-doc >= 2.2.1-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1963
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • openexr >= 2.2.1-3.6.1
  • openexr-doc >= 2.2.1-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1963
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libIlmImf-Imf_2_1-21 >= 2.1.0-6.10.1
  • openexr >= 2.1.0-6.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1962
SUSE Linux Enterprise Software Development Kit 12 SP4
  • openexr >= 2.1.0-6.10.1
  • openexr-devel >= 2.1.0-6.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1962
SUSE Linux Enterprise Software Development Kit 12 SP5
  • openexr-devel >= 2.1.0-6.13.1
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.10.1
  • openexr >= 2.1.0-6.10.1
Patchnames:
SUSE-SLE-WE-12-SP4-2019-1962
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libIlmImf-Imf_2_1-21-32bit >= 2.1.0-6.13.1
openSUSE Leap 15.0
  • libIlmImf-2_2-23 >= 2.2.1-lp150.1.1
  • libIlmImf-2_2-23-32bit >= 2.2.1-lp150.2.6.1
  • libIlmImf-2_2-23-32bit-debuginfo >= 2.2.1-lp150.2.6.1
  • libIlmImf-2_2-23-debuginfo >= 2.2.1-lp150.2.6.1
  • libIlmImfUtil-2_2-23 >= 2.2.1-lp150.2.6.1
  • libIlmImfUtil-2_2-23-32bit >= 2.2.1-lp150.2.6.1
  • libIlmImfUtil-2_2-23-32bit-debuginfo >= 2.2.1-lp150.2.6.1
  • libIlmImfUtil-2_2-23-debuginfo >= 2.2.1-lp150.2.6.1
  • openexr >= 2.2.1-lp150.2.6.1
  • openexr-debuginfo >= 2.2.1-lp150.2.6.1
  • openexr-debugsource >= 2.2.1-lp150.2.6.1
  • openexr-devel >= 2.2.1-lp150.2.6.1
  • openexr-doc >= 2.2.1-lp150.2.6.1
Patchnames:
openSUSE Leap 15.0 GA libIlmImf-2_2-23
openSUSE-2019-1816
openSUSE Leap 15.1
  • libIlmImf-2_2-23 >= 2.2.1-lp151.4.3.1
  • libIlmImf-2_2-23-32bit >= 2.2.1-lp151.4.3.1
  • libIlmImf-2_2-23-32bit-debuginfo >= 2.2.1-lp151.4.3.1
  • libIlmImf-2_2-23-debuginfo >= 2.2.1-lp151.4.3.1
  • libIlmImfUtil-2_2-23 >= 2.2.1-lp151.4.3.1
  • libIlmImfUtil-2_2-23-32bit >= 2.2.1-lp151.4.3.1
  • libIlmImfUtil-2_2-23-32bit-debuginfo >= 2.2.1-lp151.4.3.1
  • libIlmImfUtil-2_2-23-debuginfo >= 2.2.1-lp151.4.3.1
  • openexr >= 2.2.1-lp151.4.3.1
  • openexr-debuginfo >= 2.2.1-lp151.4.3.1
  • openexr-debugsource >= 2.2.1-lp151.4.3.1
  • openexr-devel >= 2.2.1-lp151.4.3.1
  • openexr-doc >= 2.2.1-lp151.4.3.1
Patchnames:
openSUSE-2019-1826


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Desktop Applications openexr Released
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications openexr Released
SUSE Linux Enterprise 15-SP2 Module for Desktop Applications openexr Released
SUSE Linux Enterprise Desktop 12 SP2 openexr Affected
SUSE Linux Enterprise Desktop 12 SP3 openexr In progress
SUSE Linux Enterprise Desktop 12 SP4 openexr Released
SUSE Linux Enterprise High Performance Computing 12 SP4 openexr Released
SUSE Linux Enterprise High Performance Computing 12 SP5 openexr Released
SUSE Linux Enterprise Server 11 SP3 OpenEXR Released
SUSE Linux Enterprise Server 11 SP3 LTSS OpenEXR Affected
SUSE Linux Enterprise Server 11 SP4 OpenEXR Affected
SUSE Linux Enterprise Server 12 LTSS openexr Affected
SUSE Linux Enterprise Server 12 SP1 LTSS openexr Affected
SUSE Linux Enterprise Server 12 SP2 openexr Affected
SUSE Linux Enterprise Server 12 SP2 LTSS openexr Analysis
SUSE Linux Enterprise Server 12 SP3 openexr In progress
SUSE Linux Enterprise Server 12 SP4 openexr Released
SUSE Linux Enterprise Server 12 SP5 openexr Released
SUSE Linux Enterprise Server for SAP Applications 12 openexr Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openexr Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openexr Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openexr Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openexr Released
SUSE Linux Enterprise Software Development Kit 11 SP4 OpenEXR Affected
SUSE Linux Enterprise Software Development Kit 12 openexr Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 openexr In progress
SUSE Linux Enterprise Software Development Kit 12 SP4 openexr Released
SUSE Linux Enterprise Workstation Extension 12 openexr Released
SUSE Linux Enterprise Workstation Extension 12 SP2 openexr Affected