Upstream information

CVE-2020-3898 at MITRE

Description

A memory corruption issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. An application may be able to gain elevated privileges.

SUSE information

SUSE Bugzilla entries: 1168422 [RESOLVED / FIXED], 1170671 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
HPE-Helion-OpenStack-8-2020-1045
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • cups-config >= 2.2.7-3.17.1
  • libcups2 >= 2.2.7-3.17.1
SUSE Enterprise Storage 5
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-Storage-5-2020-1045
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • cups >= 2.2.7-3.17.1
  • cups-client >= 2.2.7-3.17.1
  • cups-config >= 2.2.7-3.17.1
  • cups-ddk >= 2.2.7-3.17.1
  • cups-devel >= 2.2.7-3.17.1
  • libcups2 >= 2.2.7-3.17.1
  • libcups2-32bit >= 2.2.7-3.17.1
  • libcupscgi1 >= 2.2.7-3.17.1
  • libcupsimage2 >= 2.2.7-3.17.1
  • libcupsmime1 >= 2.2.7-3.17.1
  • libcupsppdc1 >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-1083
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • cups >= 2.2.7-3.17.1
  • cups-client >= 2.2.7-3.17.1
  • cups-config >= 2.2.7-3.17.1
  • cups-devel >= 2.2.7-3.17.1
  • libcups2 >= 2.2.7-3.17.1
  • libcups2-32bit >= 2.2.7-3.17.1
  • libcupscgi1 >= 2.2.7-3.17.1
  • libcupsimage2 >= 2.2.7-3.17.1
  • libcupsmime1 >= 2.2.7-3.17.1
  • libcupsppdc1 >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1083
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • cups >= 2.2.7-3.17.1
  • cups-ddk >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-1083
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • cups >= 2.2.7-3.17.1
  • cups-devel-32bit >= 2.2.7-3.17.1
  • libcupscgi1-32bit >= 2.2.7-3.17.1
  • libcupsimage2-32bit >= 2.2.7-3.17.1
  • libcupsmime1-32bit >= 2.2.7-3.17.1
  • libcupsppdc1-32bit >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1083
SUSE Linux Enterprise Point of Sale 11 SP3
  • cups >= 1.3.9-8.46.56.11.1
  • cups-client >= 1.3.9-8.46.56.11.1
  • cups-libs >= 1.3.9-8.46.56.11.1
Patchnames:
sleposp3-cups-14341
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-1045
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • cups >= 1.3.9-8.46.56.11.1
  • cups-client >= 1.3.9-8.46.56.11.1
  • cups-libs >= 1.3.9-8.46.56.11.1
  • cups-libs-32bit >= 1.3.9-8.46.56.11.1
Patchnames:
slessp4-cups-14341
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2020-1045
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-1045
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-1045
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-1045
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-1045
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-1045
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-1045
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1045
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1045
SUSE Linux Enterprise Server 15-LTSS
  • cups >= 2.2.7-3.17.1
  • cups-client >= 2.2.7-3.17.1
  • cups-config >= 2.2.7-3.17.1
  • cups-ddk >= 2.2.7-3.17.1
  • cups-devel >= 2.2.7-3.17.1
  • libcups2 >= 2.2.7-3.17.1
  • libcups2-32bit >= 2.2.7-3.17.1
  • libcupscgi1 >= 2.2.7-3.17.1
  • libcupsimage2 >= 2.2.7-3.17.1
  • libcupsmime1 >= 2.2.7-3.17.1
  • libcupsppdc1 >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-1083
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2020-1045
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-1045
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-1045
SUSE Linux Enterprise Server for SAP Applications 15
  • cups >= 2.2.7-3.17.1
  • cups-client >= 2.2.7-3.17.1
  • cups-config >= 2.2.7-3.17.1
  • cups-ddk >= 2.2.7-3.17.1
  • cups-devel >= 2.2.7-3.17.1
  • libcups2 >= 2.2.7-3.17.1
  • libcups2-32bit >= 2.2.7-3.17.1
  • libcupscgi1 >= 2.2.7-3.17.1
  • libcupsimage2 >= 2.2.7-3.17.1
  • libcupsmime1 >= 2.2.7-3.17.1
  • libcupsppdc1 >= 2.2.7-3.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-1083
SUSE Linux Enterprise Software Development Kit 12 SP4
  • cups >= 1.7.5-20.29.1
  • cups-ddk >= 1.7.5-20.29.1
  • cups-devel >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1045
SUSE Linux Enterprise Software Development Kit 12 SP5
  • cups >= 1.7.5-20.29.1
  • cups-ddk >= 1.7.5-20.29.1
  • cups-devel >= 1.7.5-20.29.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1045
SUSE OpenStack Cloud 7
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-1045
SUSE OpenStack Cloud 8
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-1045
SUSE OpenStack Cloud Crowbar 8
  • cups >= 1.7.5-20.29.1
  • cups-client >= 1.7.5-20.29.1
  • cups-libs >= 1.7.5-20.29.1
  • cups-libs-32bit >= 1.7.5-20.29.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-1045
openSUSE Leap 15.1
  • cups >= 2.2.7-lp151.6.6.1
  • cups-client >= 2.2.7-lp151.6.6.1
  • cups-client-debuginfo >= 2.2.7-lp151.6.6.1
  • cups-config >= 2.2.7-lp151.6.6.1
  • cups-ddk >= 2.2.7-lp151.6.6.1
  • cups-ddk-debuginfo >= 2.2.7-lp151.6.6.1
  • cups-debuginfo >= 2.2.7-lp151.6.6.1
  • cups-debugsource >= 2.2.7-lp151.6.6.1
  • cups-devel >= 2.2.7-lp151.6.6.1
  • cups-devel-32bit >= 2.2.7-lp151.6.6.1
  • libcups2 >= 2.2.7-lp151.6.6.1
  • libcups2-32bit >= 2.2.7-lp151.6.6.1
  • libcups2-32bit-debuginfo >= 2.2.7-lp151.6.6.1
  • libcups2-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupscgi1 >= 2.2.7-lp151.6.6.1
  • libcupscgi1-32bit >= 2.2.7-lp151.6.6.1
  • libcupscgi1-32bit-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupscgi1-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsimage2 >= 2.2.7-lp151.6.6.1
  • libcupsimage2-32bit >= 2.2.7-lp151.6.6.1
  • libcupsimage2-32bit-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsimage2-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsmime1 >= 2.2.7-lp151.6.6.1
  • libcupsmime1-32bit >= 2.2.7-lp151.6.6.1
  • libcupsmime1-32bit-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsmime1-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsppdc1 >= 2.2.7-lp151.6.6.1
  • libcupsppdc1-32bit >= 2.2.7-lp151.6.6.1
  • libcupsppdc1-32bit-debuginfo >= 2.2.7-lp151.6.6.1
  • libcupsppdc1-debuginfo >= 2.2.7-lp151.6.6.1
Patchnames:
openSUSE-2020-555