Upstream information

CVE-2026-70651 at MITRE

Description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built without libtiff support but with ImageMagick support can overflow the combined frame height while loading a crafted multi-page TIFF through VipsForeignLoadMagick. The vulnerable calculations in libvips/foreign/magick6load.c and libvips/foreign/magick7load.c multiply the per-page Ysize by n_frames without a checked bound, which can cause a heap buffer over-read and process crash. Most package-manager builds include libtiff and do not use this affected fallback path. This issue is fixed in version 8.18.3.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v4 Scores
CVSS detail CNA (GitHub)
Base Score 6.9
Vector CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Attack Vector Local
Attack Complexity Low
Attack Requirements None
Privileges Required Low
User Interaction None
Vulnerable System Confidentiality Impact None
Vulnerable System Integrity Impact Low
Vulnerable System Availability Impact High
Subsequent System Confidentiality Impact None
Subsequent System Integrity Impact None
Subsequent System Availability Impact None
CVSSv4 Version 4.0
SUSE Bugzilla entry: 1277498 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libvips-devel >= 8.18.7-1.1
  • libvips42 >= 8.18.7-1.1
  • typelib-1_0-Vips-8.0 >= 8.18.7-1.1
  • vips-bash-completion >= 8.18.7-1.1
  • vips-doc >= 8.18.7-1.1
  • vips-modules-8.0 >= 8.18.7-1.1
  • vips-tools >= 8.18.7-1.1
Patchnames:
openSUSE-Tumbleweed-2026-12266


SUSE Timeline for this CVE

CVE page created: Mon Aug 31 11:38:19 2026
CVE page last modified: Sun Oct 25 11:44:00 2026