Upstream information

CVE-2023-45199 at MITRE

Description

Mbed TLS 3.2.x through 3.4.x before 3.5 has a Buffer Overflow that can lead to remote Code execution.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1216078 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libeverest >= 3.5.0-1.1
  • libeverest-x86-64-v3 >= 3.5.0-1.1
  • libmbedcrypto15 >= 3.5.0-1.1
  • libmbedcrypto15-x86-64-v3 >= 3.5.0-1.1
  • libmbedtls20 >= 3.5.0-1.1
  • libmbedtls20-x86-64-v3 >= 3.5.0-1.1
  • libmbedx509-6 >= 3.5.0-1.1
  • libmbedx509-6-x86-64-v3 >= 3.5.0-1.1
  • libp256m >= 3.5.0-1.1
  • libp256m-x86-64-v3 >= 3.5.0-1.1
  • mbedtls-devel >= 3.5.0-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13321


SUSE Timeline for this CVE

CVE page created: Sat Oct 7 04:00:03 2023
CVE page last modified: Sun Jun 16 02:57:13 2024