Upstream information

CVE-2023-38633 at MITRE

Description

A directory traversal problem in the URL decoder of librsvg before 2.56.3 could be used by local or remote attackers to disclose files (on the local filesystem outside of the expected area), as demonstrated by href=".?../../../../../../../../../../etc/passwd" in an xi:include element.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 7.5
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack Vector Local Network
Attack Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1213502 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
SUSE Enterprise Storage 7.1
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-Storage-7.1-2023-3208
SUSE Enterprise Storage 7
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-Storage-7-2023-3208
SUSE Liberty Linux 9
  • librsvg2 >= 2.50.7-1.el9_2.1
  • librsvg2-devel >= 2.50.7-1.el9_2.1
  • librsvg2-tools >= 2.50.7-1.el9_2.1
Patchnames:
RHSA-2023:5081
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3021
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-3021
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3021
SUSE-SLE-Module-Desktop-Applications-15-SP5-2023-3021
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-3208
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-3208
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-3208
SUSE Linux Enterprise Micro 5.2
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2023-3208
SUSE Linux Enterprise Micro 5.3
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Micro-5.3-2023-3021
SUSE Linux Enterprise Micro 5.4
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Micro-5.4-2023-3021
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-3021
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2023-3021
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-3021
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP5-2023-3021
SUSE Linux Enterprise Server 15 SP2-LTSS
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-3208
SUSE Linux Enterprise Server 15 SP3-LTSS
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-3208
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2023-3208
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
  • librsvg-devel >= 2.46.7-150200.3.9.1
  • typelib-1_0-Rsvg-2_0 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP3-2023-3208
SUSE Manager Proxy 4.2
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-3208
SUSE Manager Retail Branch Server 4.2
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.2-2023-3208
SUSE Manager Server 4.2
  • gdk-pixbuf-loader-rsvg >= 2.46.7-150200.3.9.1
  • librsvg-2-2 >= 2.46.7-150200.3.9.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-3208
openSUSE Leap 15.4
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • gdk-pixbuf-loader-rsvg-32bit >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
  • librsvg-2-2-32bit >= 2.52.10-150400.3.6.1
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • rsvg-convert >= 2.52.10-150400.3.6.1
  • rsvg-thumbnailer >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
openSUSE-SLE-15.4-2023-3021
openSUSE Leap 15.5
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • gdk-pixbuf-loader-rsvg-32bit >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
  • librsvg-2-2-32bit >= 2.52.10-150400.3.6.1
  • librsvg-devel >= 2.52.10-150400.3.6.1
  • rsvg-convert >= 2.52.10-150400.3.6.1
  • rsvg-thumbnailer >= 2.52.10-150400.3.6.1
  • typelib-1_0-Rsvg-2_0 >= 2.52.10-150400.3.6.1
Patchnames:
openSUSE-SLE-15.5-2023-3021
openSUSE Leap Micro 5.3
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
openSUSE-Leap-Micro-5.3-2023-3021
openSUSE Leap Micro 5.4
  • gdk-pixbuf-loader-rsvg >= 2.52.10-150400.3.6.1
  • librsvg-2-2 >= 2.52.10-150400.3.6.1
Patchnames:
openSUSE-Leap-Micro-5.4-2023-3021
openSUSE Tumbleweed
  • gdk-pixbuf-loader-rsvg >= 2.57.0-4.1
  • gdk-pixbuf-loader-rsvg-32bit >= 2.57.0-4.1
  • librsvg-2-2 >= 2.57.0-4.1
  • librsvg-2-2-32bit >= 2.57.0-4.1
  • librsvg-devel >= 2.57.0-4.1
  • rsvg-convert >= 2.57.0-4.1
  • rsvg-thumbnailer >= 2.57.0-4.1
  • typelib-1_0-Rsvg-2_0 >= 2.57.0-4.1
Patchnames:
openSUSE Tumbleweed GA gdk-pixbuf-loader-rsvg-2.57.0-4.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 librsvg Released
SUSE Linux Enterprise Desktop 15 SP5 librsvg Released
SUSE Linux Enterprise High Performance Computing 12 SP5 librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 librsvg Released
SUSE Linux Enterprise Micro 5.2 librsvg Released
SUSE Linux Enterprise Micro 5.3 librsvg Released
SUSE Linux Enterprise Micro 5.4 librsvg Released
SUSE Linux Enterprise Micro 5.5 librsvg Affected
SUSE Linux Enterprise Micro for Rancher 5.2 librsvg Released
SUSE Linux Enterprise Micro for Rancher 5.3 librsvg Released
SUSE Linux Enterprise Micro for Rancher 5.4 librsvg Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 librsvg Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 librsvg Released
SUSE Linux Enterprise Module for Package Hub 15 SP4 librsvg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 librsvg Released
SUSE Linux Enterprise Real Time 15 SP3 librsvg Released
SUSE Linux Enterprise Server 12 SP5 librsvg Not affected
SUSE Linux Enterprise Server 15 SP5 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 librsvg Released
SUSE Linux Enterprise Software Development Kit 12 SP5 librsvg Not affected
SUSE Manager Proxy 4.3 librsvg Released
SUSE Manager Retail Branch Server 4.3 librsvg Released
SUSE Manager Server 4.3 librsvg Released
openSUSE Leap 15.5 librsvg Released
openSUSE Leap Micro 5.3 librsvg Released
openSUSE Leap Micro 5.4 librsvg Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 librsvg Released
SUSE Linux Enterprise High Performance Computing 15 librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 librsvg Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS librsvg Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS librsvg Released
SUSE Linux Enterprise High Performance Computing 15 SP3 librsvg Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS librsvg Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS librsvg Released
SUSE Linux Enterprise High Performance Computing 15 SP4 librsvg Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS librsvg Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS librsvg Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS librsvg Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS librsvg Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 librsvg Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 librsvg Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 librsvg Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 librsvg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 librsvg Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 librsvg Released
SUSE Linux Enterprise Server 12 SP2-BCL librsvg Not affected
SUSE Linux Enterprise Server 15 SP2 librsvg Affected
SUSE Linux Enterprise Server 15 SP2-LTSS librsvg Released
SUSE Linux Enterprise Server 15 SP3 librsvg Affected
SUSE Linux Enterprise Server 15 SP3-LTSS librsvg Released
SUSE Linux Enterprise Server 15 SP4 librsvg Released
SUSE Linux Enterprise Server 15 SP4-LTSS librsvg Affected
SUSE Linux Enterprise Server for SAP Applications 15 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 librsvg Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 librsvg Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 librsvg Not affected
SUSE CaaS Platform 4.0 librsvg Not affected
SUSE Enterprise Storage 6 librsvg Not affected
SUSE Enterprise Storage 7 librsvg Released
SUSE Linux Enterprise Desktop 11 SP4 librsvg Not affected
SUSE Linux Enterprise Desktop 12 SP2 librsvg Not affected
SUSE Linux Enterprise Desktop 12 SP3 librsvg Not affected
SUSE Linux Enterprise Desktop 12 SP4 librsvg Not affected
SUSE Linux Enterprise Desktop 15 librsvg Not affected
SUSE Linux Enterprise Desktop 15 SP1 librsvg Not affected
SUSE Linux Enterprise Desktop 15 SP2 librsvg Affected
SUSE Linux Enterprise Desktop 15 SP3 librsvg Affected
SUSE Linux Enterprise Module for Basesystem 15 librsvg Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 librsvg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 librsvg Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 librsvg Not affected
SUSE Linux Enterprise Module for Package Hub 15 librsvg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 librsvg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 librsvg Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 librsvg Not affected
SUSE Linux Enterprise Real Time 15 SP2 librsvg Affected
SUSE Linux Enterprise Real Time 15 SP4 librsvg Affected
SUSE Linux Enterprise Server 11 SP3 librsvg Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS librsvg Not affected
SUSE Linux Enterprise Server 11 SP4 librsvg Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS librsvg Not affected
SUSE Linux Enterprise Server 12 SP2 librsvg Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS librsvg Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS librsvg Not affected
SUSE Linux Enterprise Server 12 SP3 librsvg Not affected
SUSE Linux Enterprise Server 12 SP3-BCL librsvg Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS librsvg Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS librsvg Not affected
SUSE Linux Enterprise Server 12 SP4 librsvg Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS librsvg Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS librsvg Not affected
SUSE Linux Enterprise Server 15 librsvg Not affected
SUSE Linux Enterprise Server 15 SP1 librsvg Not affected
SUSE Linux Enterprise Server 15 SP1-BCL librsvg Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS librsvg Not affected
SUSE Linux Enterprise Server 15 SP2-BCL librsvg Affected
SUSE Linux Enterprise Server 15 SP3-BCL librsvg Affected
SUSE Linux Enterprise Server 15-LTSS librsvg Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 librsvg Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 librsvg Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 librsvg Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 librsvg Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 librsvg Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 librsvg Not affected
SUSE Manager Proxy 4.0 librsvg Not affected
SUSE Manager Proxy 4.1 librsvg Affected
SUSE Manager Proxy 4.2 librsvg Released
SUSE Manager Retail Branch Server 4.0 librsvg Not affected
SUSE Manager Retail Branch Server 4.1 librsvg Affected
SUSE Manager Retail Branch Server 4.2 librsvg Released
SUSE Manager Server 4.0 librsvg Not affected
SUSE Manager Server 4.1 librsvg Affected
SUSE Manager Server 4.2 librsvg Released
SUSE OpenStack Cloud 7 librsvg Not affected
SUSE OpenStack Cloud 8 librsvg Not affected
SUSE OpenStack Cloud 9 librsvg Not affected
SUSE OpenStack Cloud Crowbar 8 librsvg Not affected
SUSE OpenStack Cloud Crowbar 9 librsvg Not affected
openSUSE Leap 15.4 librsvg Released


SUSE Timeline for this CVE

CVE page created: Thu Jul 20 09:00:17 2023
CVE page last modified: Thu Feb 22 17:24:14 2024