Upstream information

CVE-2022-43358 at MITRE

Description

Stack overflow vulnerability in ast_selectors.cpp: in function Sass::ComplexSelector::has_placeholder in libsass:3.6.5-8-g210218, which can be exploited by attackers to cause a denial of service (DoS).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Attack Vector Network Local
Attack Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None Low
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1214575 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Package Hub 15 SP4
  • libsass-3_6_5-1 >= 3.6.5-150200.4.10.1
  • libsass-devel >= 3.6.5-150200.4.10.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2023-4895
SUSE Linux Enterprise Module for Package Hub 15 SP5
  • libsass-3_6_5-1 >= 3.6.5-150200.4.10.1
  • libsass-devel >= 3.6.5-150200.4.10.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2023-4895
openSUSE Leap 15.4
  • libsass-3_6_5-1 >= 3.6.5-150200.4.10.1
  • libsass-devel >= 3.6.5-150200.4.10.1
Patchnames:
openSUSE-SLE-15.4-2023-4895
openSUSE Leap 15.5
  • libsass-3_6_5-1 >= 3.6.5-150200.4.10.1
  • libsass-devel >= 3.6.5-150200.4.10.1
Patchnames:
openSUSE-SLE-15.5-2023-4895
openSUSE Tumbleweed
  • libsass-3_6_5-1 >= 3.6.5-2.1
  • libsass-devel >= 3.6.5-2.1
Patchnames:
openSUSE Tumbleweed GA libsass-3_6_5-1-3.6.5-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Module for Package Hub 15 SP4 libsass Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 libsass Released
openSUSE Leap 15.5 libsass Released
Products past their end of life and not receiving proactive updates anymore.
openSUSE Leap 15.4 libsass Released


SUSE Timeline for this CVE

CVE page created: Tue Aug 22 22:08:31 2023
CVE page last modified: Sat Jan 6 16:34:36 2024