Upstream information

CVE-2022-26305 at MITRE

Description

An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.8
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity High Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201868 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP5 libreoffice Affected
SUSE Linux Enterprise Desktop 15 SP3 libreoffice Affected
SUSE Linux Enterprise Desktop 15 SP4 libreoffice Affected
SUSE Linux Enterprise Server 12 SP5 libreoffice Affected
SUSE Linux Enterprise Server 15 SP3 libreoffice Affected
SUSE Linux Enterprise Server 15 SP4 libreoffice Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libreoffice Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libreoffice Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libreoffice Affected
SUSE Linux Enterprise Workstation Extension 12 SP5 libreoffice Affected
SUSE Linux Enterprise Workstation Extension 15 SP3 libreoffice Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 libreoffice Affected