Upstream information

CVE-2022-23959 at MITRE

Description

In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enterprise (Cache Plus) 4.1.x before 4.1.11r6 and 6.0.x before 6.0.9r4, request smuggling can occur for HTTP/1 connections.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 7.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1195188 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • libvarnishapi3 >= 7.1.0-bp153.2.3.1
  • varnish >= 7.1.0-bp153.2.3.1
  • varnish-devel >= 7.1.0-bp153.2.3.1
Patchnames:
openSUSE-2022-148
SUSE Package Hub 15 SP4
  • libvarnishapi3 >= 7.1.0-bp154.2.3.1
  • varnish >= 7.1.0-bp154.2.3.1
  • varnish-devel >= 7.1.0-bp154.2.3.1
Patchnames:
openSUSE-2022-144
openSUSE Leap 15.3
  • libvarnishapi3 >= 7.1.0-bp153.2.3.1
  • varnish >= 7.1.0-bp153.2.3.1
  • varnish-devel >= 7.1.0-bp153.2.3.1
Patchnames:
openSUSE-2022-148
openSUSE Leap 15.4
  • libvarnishapi3 >= 7.1.0-bp154.2.3.1
  • varnish >= 7.1.0-bp154.2.3.1
  • varnish-devel >= 7.1.0-bp154.2.3.1
Patchnames:
openSUSE-2022-144
openSUSE Tumbleweed
  • libvarnishapi3 >= 7.1.0-1.1
  • varnish >= 7.1.0-1.1
  • varnish-devel >= 7.1.0-1.1
Patchnames:
openSUSE Tumbleweed GA libvarnishapi3-7.1.0-1.1