Upstream information

CVE-2022-23097 at MITRE

Description

An issue was discovered in the DNS proxy in Connman through 1.40. forward_dns_reply mishandles a strnlen call, leading to an out-of-bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 9.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1194175 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP3
  • connman >= 1.41-bp153.2.3.1
  • connman-client >= 1.41-bp153.2.3.1
  • connman-devel >= 1.41-bp153.2.3.1
  • connman-doc >= 1.41-bp153.2.3.1
  • connman-nmcompat >= 1.41-bp153.2.3.1
  • connman-plugin-hh2serial-gps >= 1.41-bp153.2.3.1
  • connman-plugin-iospm >= 1.41-bp153.2.3.1
  • connman-plugin-l2tp >= 1.41-bp153.2.3.1
  • connman-plugin-openvpn >= 1.41-bp153.2.3.1
  • connman-plugin-polkit >= 1.41-bp153.2.3.1
  • connman-plugin-pptp >= 1.41-bp153.2.3.1
  • connman-plugin-tist >= 1.41-bp153.2.3.1
  • connman-plugin-vpnc >= 1.41-bp153.2.3.1
  • connman-plugin-wireguard >= 1.41-bp153.2.3.1
  • connman-test >= 1.41-bp153.2.3.1
Patchnames:
openSUSE-2022-56
openSUSE Leap 15.3
  • connman >= 1.41-bp153.2.3.1
  • connman-client >= 1.41-bp153.2.3.1
  • connman-devel >= 1.41-bp153.2.3.1
  • connman-doc >= 1.41-bp153.2.3.1
  • connman-nmcompat >= 1.41-bp153.2.3.1
  • connman-plugin-hh2serial-gps >= 1.41-bp153.2.3.1
  • connman-plugin-iospm >= 1.41-bp153.2.3.1
  • connman-plugin-l2tp >= 1.41-bp153.2.3.1
  • connman-plugin-openvpn >= 1.41-bp153.2.3.1
  • connman-plugin-polkit >= 1.41-bp153.2.3.1
  • connman-plugin-pptp >= 1.41-bp153.2.3.1
  • connman-plugin-tist >= 1.41-bp153.2.3.1
  • connman-plugin-vpnc >= 1.41-bp153.2.3.1
  • connman-plugin-wireguard >= 1.41-bp153.2.3.1
  • connman-test >= 1.41-bp153.2.3.1
Patchnames:
openSUSE-2022-56
openSUSE Tumbleweed
  • connman >= 1.41-1.1
  • connman-client >= 1.41-1.1
  • connman-devel >= 1.41-1.1
  • connman-doc >= 1.41-1.1
  • connman-nmcompat >= 1.41-1.1
  • connman-plugin-hh2serial-gps >= 1.41-1.1
  • connman-plugin-iospm >= 1.41-1.1
  • connman-plugin-l2tp >= 1.41-1.1
  • connman-plugin-openconnect >= 1.41-1.1
  • connman-plugin-openvpn >= 1.41-1.1
  • connman-plugin-polkit >= 1.41-1.1
  • connman-plugin-pptp >= 1.41-1.1
  • connman-plugin-tist >= 1.41-1.1
  • connman-plugin-vpnc >= 1.41-1.1
  • connman-plugin-wireguard >= 1.41-1.1
  • connman-test >= 1.41-1.1
Patchnames:
openSUSE Tumbleweed GA connman-1.41-1.1