Upstream information

CVE-2022-1227 at MITRE

Description

A privilege escalation flaw was found in Podman. This flaw allows an attacker to publish a malicious image to a public registry. Once this image is downloaded by a potential victim, the vulnerability is triggered after a user runs the 'podman top' command. This action gives the attacker access to the host filesystem, leading to information disclosure or denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1182428 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container rancher/elemental-teal-rt/5.4:latest
Container rancher/elemental-teal/5.4:latest
  • podman >= 3.4.7-150400.4.3.1
SUSE Enterprise Storage 7.1
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
SUSE-SLE-Module-Containers-15-SP3-2022-2839
SUSE-Storage-7.1-2022-2839
SUSE Liberty Linux 8
  • aardvark-dns >= 1.0.1-27.module+el8.6.0+14673+621cb8be
  • buildah >= 1.24.2-4.module+el8.6.0+14673+621cb8be
  • buildah-tests >= 1.24.2-4.module+el8.6.0+14673+621cb8be
  • cockpit-podman >= 43-1.module+el8.6.0+14673+621cb8be
  • conmon >= 2.1.0-1.module+el8.6.0+14673+621cb8be
  • container-selinux >= 2.179.1-1.module+el8.6.0+14673+621cb8be
  • containernetworking-plugins >= 1.0.1-2.module+el8.6.0+14673+621cb8be
  • containers-common >= 1.2.4-1.module+el8.6.0+14874+64436299
  • crit >= 3.15-3.module+el8.6.0+14673+621cb8be
  • criu >= 3.15-3.module+el8.6.0+14673+621cb8be
  • criu-devel >= 3.15-3.module+el8.6.0+14673+621cb8be
  • criu-libs >= 3.15-3.module+el8.6.0+14673+621cb8be
  • crun >= 1.4.4-1.module+el8.6.0+14673+621cb8be
  • fuse-overlayfs >= 1.8.2-1.module+el8.6.0+14673+621cb8be
  • libslirp >= 4.4.0-1.module+el8.6.0+14673+621cb8be
  • libslirp-devel >= 4.4.0-1.module+el8.6.0+14673+621cb8be
  • netavark >= 1.0.1-27.module+el8.6.0+14673+621cb8be
  • oci-seccomp-bpf-hook >= 1.2.3-3.module+el8.6.0+14673+621cb8be
  • podman >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-catatonit >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-docker >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-gvproxy >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-plugins >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-remote >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • podman-tests >= 4.0.2-6.module+el8.6.0+14673+621cb8be
  • python3-criu >= 3.15-3.module+el8.6.0+14673+621cb8be
  • python3-podman >= 4.0.0-1.module+el8.6.0+14673+621cb8be
  • runc >= 1.0.3-2.module+el8.6.0+14673+621cb8be
  • skopeo >= 1.6.1-2.module+el8.6.0+14673+621cb8be
  • skopeo-tests >= 1.6.1-2.module+el8.6.0+14673+621cb8be
  • slirp4netns >= 1.1.8-2.module+el8.6.0+14673+621cb8be
  • toolbox >= 0.0.99.3-1.module+el8.6.0+14874+64436299
  • toolbox-tests >= 0.0.99.3-1.module+el8.6.0+14874+64436299
  • udica >= 0.2.6-2.module+el8.6.0+14673+621cb8be
Patchnames:
RHSA-2022:1762
RHSA-2022:2143
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Containers 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
SUSE-SLE-Module-Containers-15-SP3-2022-2839
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Containers 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • podman >= 3.4.7-150400.4.3.1
  • podman-cni-config >= 3.4.7-150400.4.3.1
  • podman-docker >= 3.4.7-150400.4.3.1
  • podman-remote >= 3.4.7-150400.4.3.1
Patchnames:
SUSE-SLE-Module-Containers-15-SP4-2022-2834
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Containers 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • podman >= 4.4.4-150500.1.4
  • podman-cni-config >= 4.4.4-150500.1.4
  • podman-docker >= 4.4.4-150500.1.4
  • podman-remote >= 4.4.4-150500.1.4
Patchnames:
SUSE Linux Enterprise Module for Containers 15 SP5 GA podman-4.4.4-150500.1.4
SUSE Linux Enterprise Micro 5.1
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
SUSE-SUSE-MicroOS-5.1-2022-2839
SUSE Linux Enterprise Micro 5.2
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
SUSE-SUSE-MicroOS-5.2-2022-2839
SUSE Linux Enterprise Micro 5.3
  • podman >= 3.4.7-150400.4.3.1
  • podman-cni-config >= 3.4.7-150400.4.3.1
Patchnames:
SUSE Linux Enterprise Micro 5.3 GA podman-3.4.7-150400.4.3.1
SUSE Linux Enterprise Micro 5.4
  • podman >= 4.3.1-150400.4.11.1
  • podman-cni-config >= 4.3.1-150400.4.11.1
Patchnames:
SUSE Linux Enterprise Micro 5.4 GA podman-4.3.1-150400.4.11.1
SUSE Linux Enterprise Micro 6.0
  • podman >= 4.9.3-1.3
  • podman-docker >= 4.9.3-1.3
  • podman-remote >= 4.9.3-1.3
Patchnames:
SUSE Linux Enterprise Micro 6.0 GA podman-4.9.3-1.3
openSUSE Leap 15.3
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
openSUSE-SLE-15.3-2022-2839
openSUSE Leap 15.4
  • podman >= 3.4.7-150400.4.3.1
  • podman-cni-config >= 3.4.7-150400.4.3.1
  • podman-docker >= 3.4.7-150400.4.3.1
  • podman-remote >= 3.4.7-150400.4.3.1
Patchnames:
openSUSE-SLE-15.4-2022-2834
openSUSE Leap Micro 5.2
  • podman >= 3.4.7-150300.9.9.2
  • podman-cni-config >= 3.4.7-150300.9.9.2
Patchnames:
openSUSE-Leap-Micro-5.2-2022-2839
openSUSE Tumbleweed
  • podman >= 4.2.1-2.1
  • podman-cni-config >= 4.2.1-2.1
  • podman-docker >= 4.2.1-2.1
  • podman-remote >= 4.2.1-2.1
Patchnames:
openSUSE-Tumbleweed-2024-12400


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP5 podman Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 podman Already fixed
SUSE Linux Enterprise Micro 5.1 podman Released
SUSE Linux Enterprise Micro 5.2 podman Released
SUSE Linux Enterprise Micro 5.3 podman Released
SUSE Linux Enterprise Micro 5.4 podman Affected
SUSE Linux Enterprise Micro 5.5 podman Already fixed
SUSE Linux Enterprise Micro for Rancher 5.2 podman Released
SUSE Linux Enterprise Module for Containers 15 SP5 podman Already fixed
SUSE Linux Enterprise Module for Containers 15 SP6 podman Already fixed
SUSE Linux Enterprise Server 15 SP5 podman Already fixed
SUSE Linux Enterprise Server 15 SP6 podman Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 podman Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 podman Already fixed
SUSE Manager Proxy 4.3 podman Released
SUSE Manager Retail Branch Server 4.3 podman Released
SUSE Manager Server 4.3 podman Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 podman Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS podman Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS podman Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS podman Released
SUSE Linux Enterprise High Performance Computing 15 SP4 podman Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS podman Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS podman Affected
SUSE Linux Enterprise Module for Containers 15 SP2 podman Affected
SUSE Linux Enterprise Module for Containers 15 SP3 podman Released
SUSE Linux Enterprise Module for Containers 15 SP4 podman Released
SUSE Linux Enterprise Server 15 SP2 podman Affected
SUSE Linux Enterprise Server 15 SP2-LTSS podman Already fixed
SUSE Linux Enterprise Server 15 SP3 podman Released
SUSE Linux Enterprise Server 15 SP3-LTSS podman Affected
SUSE Linux Enterprise Server 15 SP4 podman Released
SUSE Linux Enterprise Server 15 SP4-LTSS podman Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 podman Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 podman Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 podman Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 podman Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 podman Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 podman Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 podman Already fixed
SUSE Enterprise Storage 6 podman Already fixed
SUSE Enterprise Storage 7 podman Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 podman Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS podman Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS podman Already fixed
SUSE Linux Enterprise Micro 5.0 podman Unsupported
SUSE Linux Enterprise Module for Containers 15 SP1 podman Affected
SUSE Linux Enterprise Server 15 SP1 podman Affected
SUSE Linux Enterprise Server 15 SP1-BCL podman Affected
SUSE Linux Enterprise Server 15 SP1-LTSS podman Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL podman Affected
SUSE Linux Enterprise Server 15 SP3-BCL podman Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 podman Already fixed
SUSE Manager Proxy 4.0 podman Affected
SUSE Manager Proxy 4.1 podman Already fixed
SUSE Manager Proxy 4.2 podman Released
SUSE Manager Retail Branch Server 4.0 podman Affected
SUSE Manager Retail Branch Server 4.1 podman Already fixed
SUSE Manager Retail Branch Server 4.2 podman Released
SUSE Manager Server 4.0 podman Affected
SUSE Manager Server 4.1 podman Already fixed
SUSE Manager Server 4.2 podman Released
openSUSE Leap 15.4 podman Released
Container Status
suse/sle-micro/5.5 podmanAlready fixed
rancher/elemental-teal-rt/5.4
rancher/elemental-teal/5.4
podmanReleased


SUSE Timeline for this CVE

CVE page created: Wed Apr 6 10:30:14 2022
CVE page last modified: Sun Jun 16 02:01:12 2024