Upstream information

CVE-2021-3677 at MITRE

Description

A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory. In the default configuration, any authenticated database user can complete this attack at will. The attack does not require the ability to create objects. If server settings include max_worker_processes=0, the known versions of this attack are infeasible. However, undiscovered variants of the attack may be independent of that setting.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1189748 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/postgres:10.19
Container suse/postgres:14-4.1
Container trento/trento-db:14.1-rev1.0.0-build2.2.1
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
  • libpq5 >= 13.4-5.16.2
Container suse/postgres:12-5.1
  • libpq5 >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
Container suse/postgres:13.5
  • libpq5 >= 13.4-5.16.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
Image SLES15-SP2-Manager-4-1-Server-BYOS-Azure
Image SLES15-SP2-Manager-4-1-Server-BYOS-EC2-HVM
Image SLES15-SP2-Manager-4-1-Server-BYOS-GCE
  • libpq5 >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
  • libpq5 >= 13.4-5.16.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
SUSE CaaS Platform 4.0
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-2958
SUSE Enterprise Storage 6
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-Storage-6-2022-2958
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libecpg6 >= 13.4-5.16.2
  • libpq5 >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-devel >= 12.8-8.23.2
  • postgresql12-docs >= 12.8-8.23.2
  • postgresql12-plperl >= 12.8-8.23.2
  • postgresql12-plpython >= 12.8-8.23.2
  • postgresql12-pltcl >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
  • postgresql12-server-devel >= 12.8-8.23.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-devel >= 13.4-5.16.2
  • postgresql13-docs >= 13.4-5.16.2
  • postgresql13-plperl >= 13.4-5.16.2
  • postgresql13-plpython >= 13.4-5.16.2
  • postgresql13-pltcl >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
  • postgresql13-server-devel >= 13.4-5.16.2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3255
SUSE-SLE-Module-Legacy-15-SP3-2021-3256
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-3255
SUSE-SLE-Module-Server-Applications-15-SP3-2021-3255
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libecpg6 >= 13.4-5.16.2
  • libpq5 >= 13.4-5.16.2
  • libpq5-32bit >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-devel >= 12.8-8.23.2
  • postgresql12-docs >= 12.8-8.23.2
  • postgresql12-plperl >= 12.8-8.23.2
  • postgresql12-plpython >= 12.8-8.23.2
  • postgresql12-pltcl >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
  • postgresql12-server-devel >= 12.8-8.23.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-devel >= 13.4-5.16.2
  • postgresql13-docs >= 13.4-5.16.2
  • postgresql13-plperl >= 13.4-5.16.2
  • postgresql13-plpython >= 13.4-5.16.2
  • postgresql13-pltcl >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
  • postgresql13-server-devel >= 13.4-5.16.2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3255
SUSE-SLE-Module-Basesystem-15-SP2-2021-3256
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-3255
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3255
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3256
SUSE Linux Enterprise Desktop 15 SP2
  • libpq5 >= 13.4-5.16.2
  • libpq5-32bit >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3255
SUSE-SLE-Module-Basesystem-15-SP2-2021-3256
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-3255
SUSE Linux Enterprise Desktop 15 SP3
  • libpq5 >= 13.4-5.16.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3255
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-3255
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-2958
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-2958
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Legacy 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • postgresql13 >= 13.6-5.25.1
  • postgresql13-contrib >= 13.6-5.25.1
  • postgresql13-devel >= 13.6-5.25.1
  • postgresql13-docs >= 13.6-5.25.1
  • postgresql13-llvmjit >= 13.6-5.25.1
  • postgresql13-llvmjit-devel >= 13.6-5.25.1
  • postgresql13-plperl >= 13.6-5.25.1
  • postgresql13-plpython >= 13.6-5.25.1
  • postgresql13-pltcl >= 13.6-5.25.1
  • postgresql13-server >= 13.6-5.25.1
  • postgresql13-server-devel >= 13.6-5.25.1
Patchnames:
SUSE Linux Enterprise Module for Legacy 15 SP4 GA postgresql13-13.6-5.25.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libpq5 >= 13.4-5.16.2
  • libpq5-32bit >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql13 >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-3255
SUSE-SLE-Module-Basesystem-15-SP2-2021-3256
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libpq5 >= 13.4-5.16.2
  • postgresql13 >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-3255
SUSE Linux Enterprise Module for Legacy 15 SP3
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-devel >= 12.8-8.23.2
  • postgresql12-docs >= 12.8-8.23.2
  • postgresql12-plperl >= 12.8-8.23.2
  • postgresql12-plpython >= 12.8-8.23.2
  • postgresql12-pltcl >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
  • postgresql12-server-devel >= 12.8-8.23.2
Patchnames:
SUSE-SLE-Module-Legacy-15-SP3-2021-3256
SUSE Linux Enterprise Module for Package Hub 15 SP2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-3255
SUSE Linux Enterprise Module for Package Hub 15 SP3
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-3255
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • libecpg6 >= 13.4-5.16.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-devel >= 12.8-8.23.2
  • postgresql12-docs >= 12.8-8.23.2
  • postgresql12-plperl >= 12.8-8.23.2
  • postgresql12-plpython >= 12.8-8.23.2
  • postgresql12-pltcl >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
  • postgresql12-server-devel >= 12.8-8.23.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-devel >= 13.4-5.16.2
  • postgresql13-docs >= 13.4-5.16.2
  • postgresql13-plperl >= 13.4-5.16.2
  • postgresql13-plpython >= 13.4-5.16.2
  • postgresql13-pltcl >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
  • postgresql13-server-devel >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3255
SUSE-SLE-Module-Server-Applications-15-SP2-2021-3256
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • libecpg6 >= 13.4-5.16.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-devel >= 13.4-5.16.2
  • postgresql13-docs >= 13.4-5.16.2
  • postgresql13-plperl >= 13.4-5.16.2
  • postgresql13-plpython >= 13.4-5.16.2
  • postgresql13-pltcl >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
  • postgresql13-server-devel >= 13.4-5.16.2
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP3-2021-3255
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libecpg6 >= 13.4-3.12.2
  • libpq5 >= 13.4-3.12.2
  • libpq5-32bit >= 13.4-3.12.2
  • postgresql12 >= 12.8-3.18.2
  • postgresql12-contrib >= 12.8-3.18.2
  • postgresql12-devel >= 12.8-3.18.2
  • postgresql12-docs >= 12.8-3.18.2
  • postgresql12-plperl >= 12.8-3.18.2
  • postgresql12-plpython >= 12.8-3.18.2
  • postgresql12-pltcl >= 12.8-3.18.2
  • postgresql12-server >= 12.8-3.18.2
  • postgresql12-server-devel >= 12.8-3.18.2
  • postgresql13 >= 13.4-3.12.2
  • postgresql13-contrib >= 13.4-3.12.2
  • postgresql13-devel >= 13.4-3.12.2
  • postgresql13-docs >= 13.4-3.12.2
  • postgresql13-plperl >= 13.4-3.12.2
  • postgresql13-plpython >= 13.4-3.12.2
  • postgresql13-pltcl >= 13.4-3.12.2
  • postgresql13-server >= 13.4-3.12.2
  • postgresql13-server-devel >= 13.4-3.12.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3119
SUSE-SLE-SDK-12-SP5-2021-3120
SUSE-SLE-SERVER-12-SP5-2021-3119
SUSE-SLE-SERVER-12-SP5-2021-3120
SUSE Linux Enterprise Server 15 SP1-BCL
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-2958
SUSE Linux Enterprise Server 15 SP1-LTSS
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-2958
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-2958
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postgresql12-devel >= 12.8-3.18.2
  • postgresql12-server-devel >= 12.8-3.18.2
  • postgresql13-devel >= 13.4-3.12.2
  • postgresql13-server-devel >= 13.4-3.12.2
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-3119
SUSE-SLE-SDK-12-SP5-2021-3120
SUSE Manager Proxy 4.0
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2022-2958
SUSE Manager Retail Branch Server 4.0
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2022-2958
SUSE Manager Server 4.0
  • libecpg6 >= 12.12-150100.3.33.1
  • libpq5 >= 12.12-150100.3.33.1
  • libpq5-32bit >= 12.12-150100.3.33.1
  • postgresql12 >= 12.12-150100.3.33.1
  • postgresql12-contrib >= 12.12-150100.3.33.1
  • postgresql12-devel >= 12.12-150100.3.33.1
  • postgresql12-docs >= 12.12-150100.3.33.1
  • postgresql12-plperl >= 12.12-150100.3.33.1
  • postgresql12-plpython >= 12.12-150100.3.33.1
  • postgresql12-pltcl >= 12.12-150100.3.33.1
  • postgresql12-server >= 12.12-150100.3.33.1
  • postgresql12-server-devel >= 12.12-150100.3.33.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2022-2958
openSUSE Leap 15.3
  • libecpg6 >= 13.4-5.16.2
  • libecpg6-32bit >= 13.4-5.16.2
  • libpq5 >= 13.4-5.16.2
  • libpq5-32bit >= 13.4-5.16.2
  • postgresql12 >= 12.8-8.23.2
  • postgresql12-contrib >= 12.8-8.23.2
  • postgresql12-devel >= 12.8-8.23.2
  • postgresql12-docs >= 12.8-8.23.2
  • postgresql12-llvmjit >= 12.8-8.23.2
  • postgresql12-plperl >= 12.8-8.23.2
  • postgresql12-plpython >= 12.8-8.23.2
  • postgresql12-pltcl >= 12.8-8.23.2
  • postgresql12-server >= 12.8-8.23.2
  • postgresql12-server-devel >= 12.8-8.23.2
  • postgresql12-test >= 12.8-8.23.2
  • postgresql13 >= 13.4-5.16.2
  • postgresql13-contrib >= 13.4-5.16.2
  • postgresql13-devel >= 13.4-5.16.2
  • postgresql13-docs >= 13.4-5.16.2
  • postgresql13-llvmjit >= 13.4-5.16.2
  • postgresql13-plperl >= 13.4-5.16.2
  • postgresql13-plpython >= 13.4-5.16.2
  • postgresql13-pltcl >= 13.4-5.16.2
  • postgresql13-server >= 13.4-5.16.2
  • postgresql13-server-devel >= 13.4-5.16.2
  • postgresql13-test >= 13.4-5.16.2
Patchnames:
openSUSE-SLE-15.3-2021-3255
openSUSE-SLE-15.3-2021-3256
openSUSE Tumbleweed
  • libecpg6 >= 13.4-1.3
  • libecpg6-32bit >= 13.4-1.3
  • libpq5 >= 13.4-1.3
  • libpq5-32bit >= 13.4-1.3
  • postgresql11 >= 11.13-1.3
  • postgresql11-contrib >= 11.13-1.3
  • postgresql11-devel >= 11.13-1.3
  • postgresql11-docs >= 11.13-1.3
  • postgresql11-llvmjit >= 11.13-1.3
  • postgresql11-plperl >= 11.13-1.3
  • postgresql11-plpython >= 11.13-1.3
  • postgresql11-pltcl >= 11.13-1.3
  • postgresql11-server >= 11.13-1.3
  • postgresql11-server-devel >= 11.13-1.3
  • postgresql11-test >= 11.13-1.3
  • postgresql12 >= 12.8-1.3
  • postgresql12-contrib >= 12.8-1.3
  • postgresql12-devel >= 12.8-1.3
  • postgresql12-docs >= 12.8-1.3
  • postgresql12-llvmjit >= 12.8-1.3
  • postgresql12-plperl >= 12.8-1.3
  • postgresql12-plpython >= 12.8-1.3
  • postgresql12-pltcl >= 12.8-1.3
  • postgresql12-server >= 12.8-1.3
  • postgresql12-server-devel >= 12.8-1.3
  • postgresql12-test >= 12.8-1.3
  • postgresql13 >= 13.4-1.3
  • postgresql13-contrib >= 13.4-1.3
  • postgresql13-devel >= 13.4-1.3
  • postgresql13-docs >= 13.4-1.3
  • postgresql13-llvmjit >= 13.4-1.3
  • postgresql13-plperl >= 13.4-1.3
  • postgresql13-plpython >= 13.4-1.3
  • postgresql13-pltcl >= 13.4-1.3
  • postgresql13-server >= 13.4-1.3
  • postgresql13-server-devel >= 13.4-1.3
  • postgresql13-test >= 13.4-1.3
Patchnames:
openSUSE Tumbleweed GA libecpg6-13.4-1.3
openSUSE Tumbleweed GA postgresql11-11.13-1.3
openSUSE Tumbleweed GA postgresql12-12.8-1.3


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 postgresql Not affected
HPE Helion OpenStack 8 postgresql10 Not affected
HPE Helion OpenStack 8 postgresql13 In progress
HPE Helion OpenStack 8 postgresql96 In progress
SUSE CaaS Platform 4.0 postgresql Not affected
SUSE CaaS Platform 4.0 postgresql10 Not affected
SUSE CaaS Platform 4.0 postgresql12 Released
SUSE CaaS Platform 4.5 postgresql Not affected
SUSE CaaS Platform 4.5 postgresql10 In progress
SUSE CaaS Platform 4.5 postgresql12 Released
SUSE CaaS Platform 4.5 postgresql13 Released
SUSE Enterprise Storage 6 postgresql Not affected
SUSE Enterprise Storage 6 postgresql10 Not affected
SUSE Enterprise Storage 6 postgresql12 Released
SUSE Enterprise Storage 7 postgresql Not affected
SUSE Enterprise Storage 7 postgresql10 In progress
SUSE Enterprise Storage 7 postgresql12 Released
SUSE Enterprise Storage 7 postgresql13 Released
SUSE Enterprise Storage 7.1 postgresql12 Released
SUSE Enterprise Storage 7.1 postgresql13 Released
SUSE Linux Enterprise Desktop 15 SP2 postgresql Not affected
SUSE Linux Enterprise Desktop 15 SP2 postgresql10 In progress
SUSE Linux Enterprise Desktop 15 SP2 postgresql12 Released
SUSE Linux Enterprise Desktop 15 SP2 postgresql13 Released
SUSE Linux Enterprise Desktop 15 SP3 postgresql13 Released
SUSE Linux Enterprise Desktop 15 SP4 postgresql Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql12 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql10 In progress
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql10 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql12 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 postgresql13 Released
SUSE Linux Enterprise High Performance Computing 15-LTSS postgresql Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS postgresql10 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql10 In progress
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql12 Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 postgresql13 Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 postgresql13 Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 postgresql Not affected
SUSE Linux Enterprise Module for Legacy 15 SP3 postgresql12 Released
SUSE Linux Enterprise Module for Legacy 15 SP4 postgresql Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 postgresql13 Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql10 In progress
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql12 Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 postgresql13 Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 postgresql13 Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 postgresql Not affected
SUSE Linux Enterprise Point of Service 11 SP3 postgresql Not affected
SUSE Linux Enterprise Point of Service 11 SP3 postgresql91 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Real Time 15 SP2 postgresql12 Released
SUSE Linux Enterprise Real Time 15 SP2 postgresql13 Released
SUSE Linux Enterprise Server 11 SP1 postgresql10 Not affected
SUSE Linux Enterprise Server 11 SP1 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP3 postgresql10 Not affected
SUSE Linux Enterprise Server 11 SP3 postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS postgresql94 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql Not affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL postgresql13 In progress
SUSE Linux Enterprise Server 12 SP2-BCL postgresql94 In progress
SUSE Linux Enterprise Server 12 SP2-BCL postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3-BCL postgresql Not affected
SUSE Linux Enterprise Server 12 SP3-BCL postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3-BCL postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3-ESPOS postgresql96 In progress
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP3-LTSS postgresql96 In progress
SUSE Linux Enterprise Server 12 SP4-ESPOS postgresql Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP4-LTSS postgresql Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS postgresql13 In progress
SUSE Linux Enterprise Server 12 SP5 postgresql Not affected
SUSE Linux Enterprise Server 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise Server 12 SP5 postgresql12 Released
SUSE Linux Enterprise Server 12 SP5 postgresql13 Released
SUSE Linux Enterprise Server 15 SP1-LTSS postgresql Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS postgresql12 Released
SUSE Linux Enterprise Server 15 SP2 postgresql Not affected
SUSE Linux Enterprise Server 15 SP2 postgresql10 In progress
SUSE Linux Enterprise Server 15 SP2 postgresql12 Released
SUSE Linux Enterprise Server 15 SP2 postgresql13 Released
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql12 Released
SUSE Linux Enterprise Server 15 SP2-LTSS postgresql13 Released
SUSE Linux Enterprise Server 15 SP3 postgresql12 Released
SUSE Linux Enterprise Server 15 SP3 postgresql13 Released
SUSE Linux Enterprise Server 15 SP4 postgresql Not affected
SUSE Linux Enterprise Server 15 SP4 postgresql13 Released
SUSE Linux Enterprise Server 15-ESPOS postgresql Not affected
SUSE Linux Enterprise Server 15-ESPOS postgresql10 Not affected
SUSE Linux Enterprise Server 15-LTSS postgresql Not affected
SUSE Linux Enterprise Server 15-LTSS postgresql10 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 postgresql Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 postgresql12 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 postgresql Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 postgresql10 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 postgresql12 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 postgresql13 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql13 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 postgresql96 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 postgresql13 In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql12 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 postgresql13 Released
SUSE Linux Enterprise Server for SAP Applications 15 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 15 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postgresql10 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 postgresql12 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql10 In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql12 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 postgresql13 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql12 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 postgresql13 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 postgresql13 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql12 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 postgresql13 Released
SUSE Manager Proxy 4.0 postgresql Not affected
SUSE Manager Proxy 4.0 postgresql10 Not affected
SUSE Manager Proxy 4.0 postgresql12 Released
SUSE Manager Proxy 4.1 postgresql Not affected
SUSE Manager Proxy 4.1 postgresql10 In progress
SUSE Manager Proxy 4.1 postgresql12 Released
SUSE Manager Proxy 4.1 postgresql13 Released
SUSE Manager Proxy 4.2 postgresql12 Released
SUSE Manager Proxy 4.2 postgresql13 Released
SUSE Manager Proxy 4.3 postgresql Not affected
SUSE Manager Proxy 4.3 postgresql13 Released
SUSE Manager Retail Branch Server 4.0 postgresql Not affected
SUSE Manager Retail Branch Server 4.0 postgresql10 Not affected
SUSE Manager Retail Branch Server 4.0 postgresql12 Released
SUSE Manager Retail Branch Server 4.1 postgresql Not affected
SUSE Manager Retail Branch Server 4.1 postgresql10 In progress
SUSE Manager Retail Branch Server 4.1 postgresql12 Released
SUSE Manager Retail Branch Server 4.1 postgresql13 Released
SUSE Manager Retail Branch Server 4.2 postgresql12 Released
SUSE Manager Retail Branch Server 4.2 postgresql13 Released
SUSE Manager Retail Branch Server 4.3 postgresql Not affected
SUSE Manager Retail Branch Server 4.3 postgresql13 Released
SUSE Manager Server 4.0 postgresql Not affected
SUSE Manager Server 4.0 postgresql10 Not affected
SUSE Manager Server 4.0 postgresql12 Released
SUSE Manager Server 4.1 postgresql Not affected
SUSE Manager Server 4.1 postgresql10 In progress
SUSE Manager Server 4.1 postgresql12 Released
SUSE Manager Server 4.1 postgresql13 Released
SUSE Manager Server 4.2 postgresql12 Released
SUSE Manager Server 4.2 postgresql13 Released
SUSE Manager Server 4.3 postgresql Not affected
SUSE Manager Server 4.3 postgresql13 Released
SUSE OpenStack Cloud 8 postgresql Not affected
SUSE OpenStack Cloud 8 postgresql10 Not affected
SUSE OpenStack Cloud 8 postgresql13 In progress
SUSE OpenStack Cloud 8 postgresql96 In progress
SUSE OpenStack Cloud 9 postgresql Not affected
SUSE OpenStack Cloud 9 postgresql10 Not affected
SUSE OpenStack Cloud 9 postgresql13 In progress
SUSE OpenStack Cloud Crowbar 8 postgresql Not affected
SUSE OpenStack Cloud Crowbar 8 postgresql10 Not affected
SUSE OpenStack Cloud Crowbar 8 postgresql13 In progress
SUSE OpenStack Cloud Crowbar 8 postgresql96 In progress
SUSE OpenStack Cloud Crowbar 9 postgresql Not affected
SUSE OpenStack Cloud Crowbar 9 postgresql10 Not affected
SUSE OpenStack Cloud Crowbar 9 postgresql13 In progress
SUSE Package Hub 15 postgresql Not affected
SUSE Package Hub 15 postgresql10 Not affected
SUSE Package Hub 15 SP1 postgresql Not affected
SUSE Package Hub 15 SP2 postgresql Not affected
SUSE Package Hub 15 SP2 postgresql12 Released
SUSE Package Hub 15 SP2 postgresql13 Released
SUSE Package Hub 15 SP3 postgresql13 Released
SUSE Package Hub 15 SP4 postgresql Not affected
suse/postgres:10 postgresql10Not affected
suse/postgres:12 postgresql12Released
suse/postgres:13 postgresql13Released
suse/postgres
suse/postgres:10
suse/postgres:12
suse/postgres:13
trento/trento-db
postgresqlNot affected


SUSE Timeline for this CVE

CVE page created: Tue Aug 24 15:30:13 2021
CVE page last modified: Fri Nov 25 17:50:36 2022