Upstream information

CVE-2020-6750 at MITRE

Description

GSocketClient in GNOME GLib through 2.62.4 may occasionally connect directly to a target address instead of connecting via a proxy server when configured to do so, because the proxy_addr field is mishandled. This bug is timing-dependent and may occur only sporadically depending on network delays. The greatest security relevance is in use cases where a proxy is used to help with privacy/anonymity, even though there is no technical barrier to a direct connection. NOTE: versions before 2.60 are unaffected.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 3.1
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1160668 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • glib2-devel >= 2.62.5-1.26
  • glib2-lang >= 2.62.5-1.26
  • glib2-tools >= 2.62.5-1.26
  • libgio-2_0-0 >= 2.62.5-1.26
  • libgio-2_0-0-32bit >= 2.62.5-1.26
  • libglib-2_0-0 >= 2.62.5-1.26
  • libglib-2_0-0-32bit >= 2.62.5-1.26
  • libgmodule-2_0-0 >= 2.62.5-1.26
  • libgmodule-2_0-0-32bit >= 2.62.5-1.26
  • libgobject-2_0-0 >= 2.62.5-1.26
  • libgobject-2_0-0-32bit >= 2.62.5-1.26
  • libgthread-2_0-0 >= 2.62.5-1.26
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • glib2-devel >= 2.62.6-3.6.1
  • glib2-lang >= 2.62.6-3.6.1
  • glib2-tools >= 2.62.6-3.6.1
  • libgio-2_0-0 >= 2.62.6-3.6.1
  • libgio-2_0-0-32bit >= 2.62.6-3.6.1
  • libglib-2_0-0 >= 2.62.6-3.6.1
  • libglib-2_0-0-32bit >= 2.62.6-3.6.1
  • libgmodule-2_0-0 >= 2.62.6-3.6.1
  • libgmodule-2_0-0-32bit >= 2.62.6-3.6.1
  • libgobject-2_0-0 >= 2.62.6-3.6.1
  • libgobject-2_0-0-32bit >= 2.62.6-3.6.1
  • libgthread-2_0-0 >= 2.62.6-3.6.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 3.0 glib2 Not affected
SUSE Linux Enterprise Desktop 12 SP4 glib2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 glib2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 glib2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 glib2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 glib2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 glib2 Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 SP4 glib2 Not affected
SUSE Linux Enterprise Server 12 SP5 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glib2 Not affected
SUSE Linux Enterprise Software Bootstrap Kit 12 glib2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 glib2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 glib2 Not affected
SUSE Linux Enterprise Workstation Extension 12 glib2 Not affected