Upstream information

CVE-2020-25715 at MITRE


A flaw was found in pki-core 10.9.0. A specially crafted POST request can be used to reflect a DOM-based cross-site scripting (XSS) attack to inject code into the search query form which can get automatically executed. The highest threat from this vulnerability is to data integrity.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 7
  • pki-base >= 10.5.18-12.el7_9
  • pki-base-java >= 10.5.18-12.el7_9
  • pki-ca >= 10.5.18-12.el7_9
  • pki-javadoc >= 10.5.18-12.el7_9
  • pki-kra >= 10.5.18-12.el7_9
  • pki-server >= 10.5.18-12.el7_9
  • pki-symkey >= 10.5.18-12.el7_9
  • pki-tools >= 10.5.18-12.el7_9

SUSE Timeline for this CVE

CVE page created: Wed Mar 3 12:22:54 2021
CVE page last modified: Mon Oct 30 18:11:17 2023